Big Sur on M1 machi...
 
Notifications
Clear all

[Sticky] Big Sur on M1 machines and SoftRAID issues

Page 45 / 46
Sunstarfire
(@sunstarfire)
Estimable Member

Aaaaand another update. 11.4 Beta 1 (20F5046g) works fine.

ReplyQuote
Posted : 21/04/2021 11:57 pm
(@softraid-support)
Member Admin

11.3 is good to go!

This bug is finally fixed!

 

I will be updating the forum headers. What a nightmare!

ReplyQuote
Topic starter Posted : 22/04/2021 2:15 am
pruthe liked
(@joemikeb)
Trusted Member Customer

@softraid-support

I am running macOS 11.4 beta 1 and nothing has changed since macOS 11.3 beta 7 or 8. I suppose it was too much to hope for, but I had hoped encryption and the SoftRAID 6.0.3 app's issue with APFS would have been fixed. Perhaps a subsequent macOS 11.4 beta or SoftRAID 6.0.4? 🤞

______________

Make intentional errors —
Otherwise the Great Spirit
realizes you have fulfilled
your purpose on earth.

— Navajo saying

ReplyQuote
Posted : 23/04/2021 3:12 pm
(@softraid-support)
Member Admin

APFS is on us, we will be addressing APFS in the user interface in 6.1.

 

Encryption is on macOS. We are hoping it gets addressed soon.

ReplyQuote
Topic starter Posted : 23/04/2021 10:16 pm
(@softraid-support)
Member Admin

To all who are subscribed to this thread. macOS 11.3 has been released, which fixes the M1 driver issue.

 

thanks everyone for your patience in this, it has been frustrating waiting.

ReplyQuote
Topic starter Posted : 26/04/2021 3:59 pm
(@eccles)
New Member
Posted by: @softraid-support

To all who are subscribed to this thread. macOS 11.3 has been released, which fixes the M1 driver issue.

 

thanks everyone for your patience in this, it has been frustrating waiting.

No, not fixed here, fresh install of 11.3 and softraid Extension does not load. Using Softraid 6.0.3!

ReplyQuote
Posted : 28/04/2021 3:41 am
Sunstarfire
(@sunstarfire)
Estimable Member

OK, so where does the Beta-discussion continue? Is there a dedicated thread for testing 6.1?

ReplyQuote
Posted : 28/04/2021 5:11 am
(@mountaincat)
Eminent Member

I have not had a disk lockup issue now for 11 days. I wish I could tell you what changed but nothing did that I am aware of. I don't want to jinx it, but if that issue is over I am a happy camper. Now headed to finally update SoftRAID to official version 6.

ReplyQuote
Posted : 28/04/2021 10:17 am
(@softraid-support)
Member Admin

@sunstarfire

I will open one when we have a 6.1 beta. ;-)

We are working on an interim release then on to 6.1.

ReplyQuote
Topic starter Posted : 28/04/2021 11:00 am
(@softraid-support)
Member Admin

@eccles

 

M1 works now, with 11.3. There are two reasons you may not be working

the most usual is enabling third party extensions:

https://support.apple.com/en-lk/guide/mac-help/mchl768f7291/mac
Select reduced security and enable this:
Select the “Allow user management of kernel extensions from identified developers” checkbox to allow installation of software that uses legacy kernel extensions.

Then when you "reinstall SoftRAID driver", you should get the dialog box to go to System Preferences/Security to "Allow" OWC as an identified developer?

 

If you do not see this dialog box, then the solutions is deleting obsolete extensions. Big Sur does not like old extensions hanging around. I am working on clarifying these instructions into a document.

ReplyQuote
Topic starter Posted : 28/04/2021 11:02 am
(@thierrycoopman)
Active Member

 

Is there a known issue with ThunderBlade? 

I have had issues (unresponsiveness in Finder, IO timeouts I think) with 6 Beta and 11.0/11.1. So I held out for the official 6.0.3 and 11.3 to use the device again.

The issues seems to be same/similar, even if it's a bit more "stable".

My media test is rebuilding the iCloud Photo Library of +-700GB download originals from scratch. It gets up to 30-40GB every time and then gets 'stuck'. Photos.app unresponsive, Finder unresponsive, restart waiting forever, and eventually kernel panicking.

If the device is not connected I have no issues, so my suspicion is related to the heavy IO resulting in the use of Photos.app (other use, normal files copy etc... seems to be ok). The device is formatted APFS

Attached is the kernel panic that happened when I started a reboot at the time the symptoms happened. 

Let me know how and if I can provide more info, the whole system becomes "unresponsive" at a certain point, so not sure what info I get at that moment. 

This post was modified 1 week ago by thierrycoopman
ReplyQuote
Posted : 29/04/2021 3:55 am
(@softraid-support)
Member Admin

Also attach a support file. There is no generic issue with the Thunderblade, not that you cannot have a specific issue.

the panic was a kernel bug in macOS, when shutting down, it takes too long to flush disk cache's so panics. I do not think it is specific to your thunderbay, but generally more with HDD's. (unless one of your blades is hanging)

ReplyQuote
Topic starter Posted : 29/04/2021 4:19 am
(@thierrycoopman)
Active Member

@softraid-support

I seem to be able to repeat this issue, so I guess that is a good thing. When the issue happens, I'm not sure if I can generate a report, as all IO to the Thunderblade seems blocked. 

I ran the report now (just after connecting the drive) and attached it, and I'll try to get a report when the issue happens again, but since the OS is more or less blocked every time the drive is involved, there is no guarantee.

 

ReplyQuote
Posted : 30/04/2021 3:21 am
(@thierrycoopman)
Active Member

 

@softraid-support

Got it reproduced after 10 minutes

When asking the Support report, SoftRaid "stopped responding", and I requested the sample through Activity Monitor. 

Then I started using the disk through Finder, and the computer locked up. 

To note, I used this device on Catalina Intel Macs before without any issues, what is different:

- M1 versus Intel

- APFS versus HFS+

- Big Sur versus Catalina

- Softraid 6 verus Softraid 5

 

I consider any of these changes the possible culprit, but it's hard to get pin it down. 

 

 

 

 

Untitled sr blocked

 

ReplyQuote
Posted : 30/04/2021 3:51 am
(@softraid-support)
Member Admin

I am seeing a handful of these kinds of crashes all of a sudden, mostly watchdog panics. (A couple are "dart", which may be a hardware issue.)

My money is on M1, but its a guess.

Can you generate a system Diagnose file after a crash?

sudo sysdiagnose -f ~/Desktop/

I can tell you how to get it to us once you have it.

 

 

 

ReplyQuote
Topic starter Posted : 30/04/2021 5:13 pm
Page 45 / 46
Share:
close
open