Big Sur on M1 machi...
 
Notifications
Clear all

[Sticky] Big Sur on M1 machines and SoftRAID issues

Page 47 / 59
(@tma-one)
New Member

I have been experiencing very frequent kernel panics with a Mac mini M1, a thunderbay 8, and with both SoftRAID versions 6.0.3 and 6.0.4.b9.

I have two RAID 5 disk sets both with APFS filesystems, however one volume created with a previous SoftRAID version and one with 6.0.4.b9 on an intel mabook pro. 

When I moved the thunderbay to the M1 Mac mini, I started experiencing repeated kernel panics even from the login screen, where the system eventually boots into Kernel Medic Mode, whereby it disables all kernel extensions (and therefore not allowing any access to the volumes/disks).

 

A couple of interesting details that may help in troubleshooting this: when there is only one of the volumes mounted, the recently created one (With 6.0.4.b9), then the kernel panic's stop and I can also access the volume and perform also IO intensive operations. However when the other volume is also mounted I am expected to have a kernel panic, within 5-10 minutes while it is also true that this volume also hosts a home folder location for one user of the system.

I have mainly tried installing/uninstalling/clearing the kernel cache. 

 

ReplyQuote
Posted : 11/05/2021 8:07 am
(@softraid-support)
Member Admin

@joemikeb

If you can get the before after, that would be great. We are still collecting data on this issue.

ReplyQuote
Topic starter Posted : 11/05/2021 9:17 am
(@softraid-support)
Member Admin

@tma-one

Can you attach a SoftRAID tech support file? Also, next crash, click "report to Apple", then more details and paste the results into a text edit file, and save it as .txt and attach it  also. thanks

ReplyQuote
Topic starter Posted : 11/05/2021 9:28 am
(@tma-one)
New Member

@softraid-support

Please find attached the requested files below.

 

ReplyQuote
Posted : 11/05/2021 11:58 am
(@softraid-support)
Member Admin

@tma-one

If you connect both enclosures a couple minutes after startup, do you still get the panics?

 

Are you willing to help me capture a macOS core dump? (troubleshooting onformation)

ReplyQuote
Topic starter Posted : 11/05/2021 2:23 pm
(@tma-one)
New Member

@softraid-support

 

There aren't two enclosures, there is one enclosure (a thunderbay 8) with two RAID5 volumes, i.e., one volume with 4x WD 4TB disks, and another volume with 4x WD 8TB disks.

Yes, as soon as there one volume mounted (the 4x8TB one) irrespectively if it was mounted during boot or even a few minutes after boot, the panics are guaranteed to occur (I've tried this as you suggested).

Yes, I'm happy to help out in capturing a coredump in order to troubleshoot this further. 

 

ReplyQuote
Posted : 11/05/2021 4:59 pm
(@softraid-support)
Member Admin

@tma-one

Great. It may take a day or two for me to know what we need to collect. It may just be a core dump, or we may create a debug version of the driver also.

ReplyQuote
Topic starter Posted : 11/05/2021 6:25 pm
(@joemikeb)
Trusted Member Customer

@softraid-support

This is a suggestion not a bug. I am currently running MacOS 11.4 beta 3 on an M1 Mac mini and this morning I attempted to install SoftRAID 6.0.4. I won't bore you with all the various attempts to install 6.0.4 and uninstall 6.0.3 so cutting to the chase. The 6.0.4 app reported success every time, some times the necessity of a reboot was indicated. The necessity of approving the install in System Preferences > Security & Privacy was never indicated either by the installer or MacOS. I have no idea why MacOS did not throw a notification, but it would seem the SoftRAID app could at least warn the user of the necessity of approving the install and/or even open System Preferences > Security & Privacy automatically. 

______________

Make intentional errors —
Otherwise the Great Spirit
realizes you have fulfilled
your purpose on earth.

— Navajo saying

ReplyQuote
Posted : 12/05/2021 11:17 am
(@softraid-support)
Member Admin

@joemikeb

I do 100% agree with you. This has been a lower priority because of other fires we have had to address. but installation clarity and simplification is on the menu for the not far future. thanks for the feedback.

One problem is all these issues are from changes in macOS security and the SoftRAID driver methodology when designed assumed all the OS rules would be followed. Now that they are not, it is a relatively major effort to do this without writing special case code, which is hard to maintain over years. So we intend to try to redesign this so it is both easier on users and maintainable going forward.

thanks

ReplyQuote
Topic starter Posted : 12/05/2021 1:30 pm
(@antonyrock)
Trusted Member

al

2021 05 19 03 14 18

m1 11.3.1
soft raid 6.0.4

the driver is installed
the same thing. restarting doesn't work

Could you help me plz ?

This post was modified 2 years ago 3 times by antonyRock
ReplyQuote
Posted : 18/05/2021 7:18 pm
(@softraid-support)
Member Admin

@antonyrock

Do you have this setting set:

 

https://support.apple.com/en-lk/guide/mac-help/mchl768f7291/mac
Select reduced security and enable this:
Select the “Allow user management of kernel extensions from identified developers” checkbox to allow installation of software that uses legacy kernel extensions.

ReplyQuote
Topic starter Posted : 19/05/2021 1:04 pm
(@romanmf)
New Member

Just got an M1 Mac mini in today. Had two kernel panics once I got the 6.0.4 installed and the volume actually mounted. Uninstalled and reinstalled and haven't had a kernel panic again, but performance is woeful. Drives take forever to spin up. It's noticeably slower than it was on my 2018 Intel MBP which was also running Big Sur. IDK. I'm going to keep messing with it. The kernel panics were super spooky on the brand new machine. 

ReplyQuote
Posted : 19/05/2021 11:08 pm
(@softraid-support)
Member Admin

@romanmf

Did you save any of the kernel panics?

Look in activity Monitor for anything taking up CPU's.

Your machine ought to be extremely snappy!

YOu can attach a support file from SoftRAID and I can take a look.

ReplyQuote
Topic starter Posted : 19/05/2021 11:20 pm
(@romanmf)
New Member

@softraid-support

Oh the machine itself is speedy, the RAID is not. I do have the kernel panic log. Would that be helpful to send?

ReplyQuote
Posted : 20/05/2021 12:30 am
(@thedutchvideoguy)
New Member

Hello, I got the Error. It said: SoftRAID Error, An error occurred creating the volume ""Storage"". SoftRAID was unable to create a file system on this volume. The OWC Thunderbay 4 is connected to my Apple M1 Macbook Air on Big Sur 11.3.1. I uninstalled the software and tried again. I also changed the security to Reduced Security with both options enabled. I also added full disk access to SoftRAID.

So what can I do next. I cannot use it.

ReplyQuote
Posted : 20/05/2021 3:04 am
Page 47 / 59
Share:
close
open