Notifications
Clear all

With SoftRAID enabled, Mac Pros won’t power down

(@nightwatch)
Active Member Customer

I’ve tried combing the console to see if I could spot the issue but no luck with that.

I have a fairly unique setup.

I have 4 Samsung SM951s ACHI type inside one of these in PCIe Slot 2. I use it to lessen the I/O bottleneck between the CPU, the RAM and the drives that exist with audio samplers, (due to the size of audio sample libraries one must have some samples in RAM and some ready on extremely fast storage, and it really helps to use m.2 SSDs in a RAID in the PCIe bus. It’s great for FCPX too!

I get an amazing 5.7GBs reads and 5GBs writes with the SoftRAID driver controlling the RAID 0. But my 4,1 MP (with the 5,1 firmware upgrade and x5690 Xeons), won’t shut down when SoftRAID is enabled. It hangs after the screens go dark and I have to press and hold the power-on button until it shuts down.

With SoftRAID disabled and the AppleRAID driver enabled I get much slower writes, and slower reads, but no issues with shutting down.

I’ve tested this with several versions of SoftRAID, over the past year, all with the same result. Would really really love to start using SoftRAID again, but I can’t.

Any suggestions? Would sending logs after a reboot possibly tell you the reason, or is there an inherent conflict with this setup? Oh, I am booting macOS off of one SM951 ACHI in PCIe slot 3.

Thank you,
Steve

Quote
Topic starter Posted : 25/01/2019 10:04 pm
(@softraid-support)
Member Admin

A SoftRAID tech support file might help. Its possible we would need to see the hardware to figure this out. You did not mention the OS, I presume Mohave?

We are aware of an OS X hang on Thunderbolt with lots of devices connected, which we reported to Apple. We replicated that issue with the Apple drivers, so the case I am aware of is not a SoftRAID specific issue.

If yours is the same bug, that means it has existed a long time, as you are not running thunderbolt.

ReplyQuote
Posted : 26/01/2019 10:03 am
(@muaddib)
New Member Customer

Hello

I am having the same problem. Since I installed Softraid Lite XT 5.8.3, when ever I shut down the computer to restart the screen turns black as it should and then the white shut down wheel goes round and round and never completes the shut down.  I finally have to press the power button to turn it off.  I have a iMac 2011 27 inch 32 Gig Ram running High Sierra. Attached is a Akito Thunderbolt RAID quad mini with 4 SSD in Raid 0 format,  and 2 USB hard drives attached as well. The problem occurs even when I boot off one of my USB HD boot drives which has High Sierra installed. I installed Softraid on my USB drive so I could access the Thunderbolt Raid.

It is not a big deal to press the power button, I am just worried that it may damage some of the system files and corrupt things.

Any suggestions on how to solve this.

Thanks

 

Kip

ReplyQuote
Posted : 14/07/2020 3:24 pm
(@softraid-support)
Member Admin

When you restart, you must get a kernel panic alert. What does that say? (click more info)

Does this happen if both the USB drives are disconnected?

ReplyQuote
Posted : 15/07/2020 1:45 pm
(@muaddib)
New Member Customer

I updated to SoftRaid XT Lite 5.8.4 and that seem to have fixed the problem.

ReplyQuote
Posted : 16/07/2020 12:15 pm
Share:
close
open