Sleep support?
 
Notifications
Clear all

Sleep support?

Page 3 / 4
(@softraid-support)
Member Admin

@gvansteelant

If you paste this into terminal, does it mount? (A temporary solution)

 

sudo kmutil load -p /Library/Extensions/SoftRAID.kext

ReplyQuote
Posted : 02/06/2021 10:53 am
(@gvansteelant)
Eminent Member Customer
Posted by: @softraid-support

@gvansteelant

If you paste this into terminal, does it mount? (A temporary solution)

 

sudo kmutil load -p /Library/Extensions/SoftRAID.kext

That's what I've been using (and now still use), yes.

ReplyQuote
Topic starter Posted : 03/06/2021 12:00 am
(@d-j-hsu)
New Member

My friend’s Mac mini encountered the same problem yesterday after upgrading macOS from 11.3.1 to 11.4. He solved the problem too. But he had to delete "Default.plist" and "KextPolicy" files in /var/db/SystemPolicyConfiguration folder. 

ReplyQuote
Posted : 03/06/2021 4:46 am
(@softraid-support)
Member Admin

@d-j-hsu

I dont like having to do this brute force approach, but until we understand Big Sur's issue here better, at least it works.

ReplyQuote
Posted : 03/06/2021 10:45 am
(@gvansteelant)
Eminent Member Customer
Posted by: @d-j-hsu

My friend’s Mac mini encountered the same problem yesterday after upgrading macOS from 11.3.1 to 11.4. He solved the problem too. But he had to delete "Default.plist" and "KextPolicy" files in /var/db/SystemPolicyConfiguration folder. 

Tried that and the fix still doesn't survive a reboot.

ReplyQuote
Topic starter Posted : 04/06/2021 2:15 am
(@softraid-support)
Member Admin

@gvansteelant

Use the temporary workaround, until we can understand this. (or we get a response from Apple on fixing this issue)

 

sudo kmutil load -p /Library/Extensions/SoftRAID.kext

ReplyQuote
Posted : 04/06/2021 9:58 am
(@smckenzie)
Active Member

This has been going on for me for a number of years now. Randomly the volumes will be locked when woken from sleep but more recently it also results in a kernel crash and a restart. This happened with the previous version of SoftRaid as well as V6 on Big Sur. It’s at the point where I’m looking for an alternative.

ReplyQuote
Posted : 04/06/2021 4:09 pm
(@softraid-support)
Member Admin

@smckenzie

Please if you get a kernel panic, can you "report to Apple", click more info, then save all the text in a text edit file and save it as text? (plain text) I would like to see the panic report. thanks!

ReplyQuote
Posted : 04/06/2021 10:49 pm
(@smckenzie)
Active Member

Woke from sleep, then it hung and restarted.

 

Wasn't able to upload the plain text file.

 

panic(cpu 8 caller 0xffffff80007c58f6): Kernel trap at 0xffffff800327c6e6, type 14=page fault, registers:
CR0: 0x000000008001003b, CR2: 0x00000000000001f8, CR3: 0x0000000014809000, CR4: 0x00000000003626e0
RAX: 0x0000000000000000, RBX: 0xffffffa0963142d0, RCX: 0x000000000000021c, RDX: 0x0000000000000000
RSP: 0xffffffc1b2fa3e20, RBP: 0xffffffc1b2fa3e60, RSI: 0x0000000000000000, RDI: 0xffffff8720fce3c0
R8:  0x0000000000000056, R9:  0x0000000000000010, R10: 0xffffff8000ef0a40, R11: 0x0000000000000000
R12: 0xffffffa184088e40, R13: 0x000000000100003c, R14: 0xffffff93c8ce98e0, R15: 0xffffff8720fce3c0
RFL: 0x0000000000010246, RIP: 0xffffff800327c6e6, CS:  0x0000000000000008, SS:  0x0000000000000010
Fault CR2: 0x00000000000001f8, Error code: 0x0000000000000000, Fault CPU: 0x8, PL: 0, VF: 1

Backtrace (CPU 8), Frame : Return Address
0xffffffc1b2fa3840 : 0xffffff800068e0dd 
0xffffffc1b2fa3890 : 0xffffff80007d4f33 
0xffffffc1b2fa38d0 : 0xffffff80007c552a 
0xffffffc1b2fa3920 : 0xffffff8000632a2f 
0xffffffc1b2fa3940 : 0xffffff800068d8fd 
0xffffffc1b2fa3a60 : 0xffffff800068dbf3 
0xffffffc1b2fa3ad0 : 0xffffff8000e9d81a 
0xffffffc1b2fa3b40 : 0xffffff80007c58f6 
0xffffffc1b2fa3cc0 : 0xffffff80007c55dd 
0xffffffc1b2fa3d10 : 0xffffff8000632a2f 
0xffffffc1b2fa3d30 : 0xffffff800327c6e6 
0xffffffc1b2fa3e60 : 0xffffff7f9d1363e9 
0xffffffc1b2fa3ec0 : 0xffffff7f9d134bc7 
0xffffffc1b2fa3ee0 : 0xffffff8000def2b0 
0xffffffc1b2fa3f30 : 0xffffff8000deda1e 
0xffffffc1b2fa3f70 : 0xffffff8000ded006 
0xffffffc1b2fa3fa0 : 0xffffff800063213e 
      Kernel Extensions in backtrace:
         com.apple.iokit.IOStorageFamily(2.1)[A0D72FE9-649B-316A-8B5C-934E295FF0B5]@0xffffff800326d000->0xffffff800327efff
         com.softraid.driver.SoftRAID(6.0.5)[E6447899-F7A5-3524-B637-5BAEB4A09DAA]@0xffffff7f9d112000->0xffffff7f9d140fff
            dependency: com.apple.iokit.IOStorageFamily(2.1)[A0D72FE9-649B-316A-8B5C-934E295FF0B5]@0xffffff800326d000->0xffffff800327efff

Process name corresponding to current thread: kernel_task

Mac OS version:
20F71

Kernel version:
Darwin Kernel Version 20.5.0: Sat May  8 0533 PDT 2021; root:xnu-7195.121.3~9/RELEASE_X86_64
Kernel UUID: 52A1E876-863E-38E3-AC80-09BBAB13B752
KernelCache slide: 0x0000000000400000
KernelCache base:  0xffffff8000600000
Kernel slide:      0x0000000000410000
Kernel text base:  0xffffff8000610000
__HIB  text base: 0xffffff8000500000
System model name: iMac20,2 (Mac-AF89B6D9451A490B)
System shutdown begun: NO
Hibernation exit count: 0

System uptime in nanoseconds: 37284648955824
Last Sleep:           absolute           base_tsc          base_nano
  Uptime  : 0x000021e90241b464
  Sleep   : 0x000021d41eedbe55 0x00000000abc91e94 0x000021c525107226
  Wake    : 0x000021d42683a080 0x00000000ac35f970 0x000021d422f8afba
last started kext at 7100693036332: @filesystems.msdosfs	1.10 (addr 0xffffff7f9bead000, size 57344)
loaded kexts:
com.owc.driver.SCSI-Device	1.1.0b16
com.owc.driver.SATA-Command	8.1.0b16
com.intel.driver.EnergyDriver	3.6.0
com.softraid.driver.SoftRAID	6.0.5
@filesystems.msdosfs	1.10
>!ATopCaseHIDEventDriver	4050.1
>!APlatformEnabler	2.7.0d0
>AGPM	122.1
>X86PlatformShim	1.0.0
@filesystems.autofs	3.0
@fileutil	20.036.15
>!AHIDALSService	1
>!AUpstreamUserClient	3.6.8
@kext.AMDRadeonX6000	4.0.5
@kext.AMDRadeonServiceManager	4.0.5
>!AGraphicsDevicePolicy	6.3.3
@AGDCPluginDisplayMetrics	6.3.3
>pmtelemetry	1
|IOUserEthernet	1.0.1
>usb.!UUserHCI	1
|IO!BSerialManager	8.0.5d7
>AGDCBacklightControl	6.3.3
@Dont_Steal_Mac_OS_X	7.0.0
>!ABacklight	180.3
>!AHV	1
>!ADiskImages2	1
>ACPI_SMC_PlatformPlugin	1.0.0
>!ABridgeAudio!C	140.4
>!A!IKBLGraphics	16.0.4
>!AMCCSControl	1.14
>!AGFXHDA	100.1.433
>!AThunderboltIP	4.0.3
>!A!ISlowAdaptiveClocking	4.0.0
>!AMuxControl2	6.3.3
>!A!IPCHPMC	2.0.1
>BridgeAudioCommunication	140.4
>!A!ICFLGraphicsFramebuffer	16.0.4
>!AAVEBridge	6.1
>!AFIVRDriver	4.1.0
@!AEthernetAquantiaAqtionFirmware	1.0.36
|SCSITaskUserClient	436.121.1
>!UCardReader	511.120.2
>BCMWLANFirmware4378.Hashstore	1
>BCMWLANFirmware4377.Hashstore	1
>BCMWLANFirmware4364.Hashstore	1
>BCMWLANFirmware4355.Hashstore	1
>!AFileSystemDriver	3.0.1
@filesystems.tmpfs	1
@filesystems.hfs.kext	556.100.11
@BootCache	40
@!AFSCompression.!AFSCompressionTypeZlib	1.0.0
@!AFSCompression.!AFSCompressionTypeDataless	1.0.0d1
>!AAHCIPort	346.100.2
>!ABCMWLANBusInterfacePCIeMac	1
@filesystems.apfs	1677.120.9
@private.KextAudit	1.0
>!AACPIButtons	6.1
>!ASMBIOS	2.1
>!AACPIEC	6.1
>!AAPIC	1.7
@!ASystemPolicy	2.0.0
@nke.applicationfirewall	311
|IOKitRegistryCompatibility	1
|EndpointSecurity	1
|IOATA!F	2.5.3
>!UAudio	405.39
>!AHIDKeyboard	224
>!AMultitouchDriver	4440.3
>!AInputDeviceSupport	4400.35
>!AHS!BDriver	4050.1
>IO!BHIDDriver	8.0.5d7
@kext.triggers	1.0
@kext.AMDRadeonX6200HWLibs	1.0
@kext.AMDRadeonX6000HWServices	4.0.5
|IOAVB!F	940.4
|IOEthernetAVB!C	1.1.0
>!ABacklightExpert	1.1.0
>IOPlatformPluginLegacy	1.0.0
>X86PlatformPlugin	1.0.0
|IO!BHost!CUARTTransport	8.0.5d7
|IO!BHost!CTransport	8.0.5d7
>!ASMBusPCI	1.0.14d1
@!AGPUWrangler	6.3.3
@plugin.IOgPTPPlugin	985.2
>!ASMBus!C	1.0.18d1
>!AHDA!C	283.15
|IOHDA!F	283.15
|IOAudio!F	300.6.1
@vecLib.kext	1.2.0
@kext.AMDRadeonX6000Framebuffer	4.0.5
|IOSlowAdaptiveClocking!F	1.0.0
@kext.AMDSupport	4.0.5
>!AThunderboltEDMSink	5.0.3
>!AGraphicsControl	6.3.3
|IONDRVSupport	585.1
>IOPlatformPlugin!F	6.0.0d8
|IOAccelerator!F2	442.9
@!AGraphicsDeviceControl	6.3.3
|IOGraphics!F	585.1
>!A!ILpssUARTv1	3.0.60
>!A!ILpssUARTCommon	3.0.60
>!AOnboardSerial	1.0
>!AThunderboltPCIUpAdapter	4.1.1
>!AThunderboltDPOutAdapter	8.1.4
>!AThunderboltDPInAdapter	8.1.4
>!AThunderboltDPAdapter!F	8.1.4
>!AThunderboltPCIDownAdapter	4.1.1
>!AHPM	3.4.4
>!A!ILpssI2C!C	3.0.60
>!A!ILpssI2C	3.0.60
>!A!ILpssDmac	3.0.60
>usb.IOUSBHostHIDDevice	1.2
>usb.cdc.ecm	5.0.0
>usb.cdc.ncm	5.0.0
>usb.cdc	5.0.0
>usb.networking	5.0.0
>usb.!UHostCompositeDevice	1.2
>!ABSDKextStarter	3
|IOSurface	290.8.1
@filesystems.hfs.encodings.kext	1
|IOAHCIBlock!S	332
|IOAHCI!F	294.100.1
>!AThunderboltNHI	7.2.8
|IOThunderbolt!F	9.3.2
>!AEthernetAquantiaAqtion	1.0.64
>!ABCMWLANCoreMac	1.0.0
|IOSerial!F	11
|IO80211!FV2	1200.12.2b1
|IOSkywalk!F	1
>mDNSOffloadUserClient	1.0.1b8
>IOImageLoader	1.0.0
>corecapture	1.0.4
>!AXsanScheme	3
>usb.!UVHCIBCE	1.2
>usb.!UVHCICommonBCE	1.0
>usb.!UVHCI	1.2
>usb.!UVHCICommon	1.0
>!AEffaceableNOR	1.0
|IOBufferCopy!C	1.1.0
|IOBufferCopyEngine!F	1
|IONVMe!F	2.1.0
>usb.!UXHCIPCI	1.2
>usb.!UXHCI	1.2
>usb.!UHostPacketFilter	1.0
|IOUSB!F	900.4.2
>!AEFINVRAM	2.1
>!AEFIRuntime	2.1
>!ASMCRTC	1.0
|IOSMBus!F	1.1
|IOHID!F	2.0.0
$!AImage4	3.0.0
|IOTimeSync!F	985.2
|IONetworking!F	3.4
>DiskImages	493.0.0
|IO!B!F	8.0.5d7
|IOReport!F	47
|IO!BPacketLogger	8.0.5d7
$quarantine	4
$sandbox	300.0
@kext.!AMatch	1.0.0d1
|CoreAnalytics!F	1
>!ASSE	1.0
>!AKeyStore	2
>!UTDM	511.120.2
|IOUSBMass!SDriver	184.121.1
|IOSCSIBlockCommandsDevice	436.121.1
|IO!S!F	2.1
|IOSCSIArchitectureModel!F	436.121.1
>!AMobileFileIntegrity	1.0.5
@kext.CoreTrust	1
>!AFDEKeyStore	28.30
>!AEffaceable!S	1.0
>!ACredentialManager	1.0
>KernelRelayHost	1
|IOUSBHost!F	1.2
>!UHostMergeProperties	1.2
>usb.!UCommon	1.0
>!ABusPower!C	1.0
>!ASEPManager	1.0.1
>IOSlaveProcessor	1
>!AACPIPlatform	6.1
>!ASMC	3.1.9
|IOPCI!F	2.9
|IOACPI!F	1.4
>watchdog	1
@kec.pthread	1
@kec.corecrypto	11.1
@kec.Libm	1
ReplyQuote
Posted : 17/06/2021 1:18 pm
(@softraid-support)
Member Admin

@smckenzie

This crash is happening in the file system, but not sure what is triggering it.

Could be indexing, for example. Try disable spotlight on this volume.

I did some searching and it is most likely an issue inside the RAID volume. The reason SoftRAID is in the middle is that is how the driver works, it is asked where to push dattaa, then it answers and the file system goes out to write the data. It is "in the middle" of the trace, which says it handed off the read/write.

Its also possible it is from some file system damage. When you have time, do a backup/restore, as an example.

ReplyQuote
Posted : 17/06/2021 4:18 pm
(@smckenzie)
Active Member

@softraid-support

Thanks for taking the time to look at that.

SoftRaid doesn't report any errors, but it is slow to look up files.

ReplyQuote
Posted : 17/06/2021 5:53 pm
(@softraid-support)
Member Admin

@smckenzie

Do you mean opening folders can beach ball for a few moments, or there are long pauses?

Do you have access to Disk Warrior? it is best at repairing damaged directories. Or, this weekend, do a backup/restore. that may fix your issues. I hope so!

ReplyQuote
Posted : 17/06/2021 6:13 pm
(@smckenzie)
Active Member

@softraid-support

Sometimes beachball but more often lots of activity an all disks with nothing doing. I'm frequently browsing images, (this is what the volume is used for), even jpegs sometimes it can take an age to generate a preview even when its a small file.

I do have DiskWarrior but its probably out of date.

ReplyQuote
Posted : 17/06/2021 6:17 pm
(@softraid-support)
Member Admin

@smckenzie

Probably a backup/restore, then.

ReplyQuote
Posted : 17/06/2021 6:49 pm
(@smckenzie)
Active Member

@softraid-support

Turns out I have Disk Warrior 5.2 but I don't see the soft raid array in the list to repair.

ReplyQuote
Posted : 17/06/2021 8:22 pm
Page 3 / 4
Share:
close
open