Notifications
Clear all

Won't Mount - softRaid 6.2 - Mac mini M1 - Monterey

(@sleepyninja)
New Member

Hi, I just bought a OWC Thunderbay 4.

I have a mac mini m1, running Monterey 

I have softraid 6.2

 

I try to mount and it lets me enter password, then nothing.

I tried to change enable, safeguard. nothing

Change optimize for a fifferent workstation, nothing.

 

I have tried unistall, reinstall drivers. 

Please help.

Thanks

Quote
Topic starter Posted : 09/12/2021 12:16 pm
(@softraid-support)
Member Admin

When you restart, do you get the option to "report to Apple"? Click more details and copy/paste the text into text edit or bbedit and save as txt. Attach it, so I can see the panic report. thanks!

ReplyQuote
Posted : 09/12/2021 1:37 pm
(@sleepyninja)
New Member

HI thanks for the response! When I restart the computer, i get 4 pop ups saying "the disk you attached was not readable by the computer"

Nothing saying "report to apple." I also attached an image of part of my softRaid Log. It said. -command 94 encountered the error -50

 

Thanks!

Screen Shot 2021 12 09 at 2.35.28 PM

 

Screen Shot 2021 12 09 at 2.38.01 PM

 

 

ReplyQuote
Topic starter Posted : 09/12/2021 4:44 pm
(@softraid-support)
Member Admin

@sleepyninja 

Those messages are because the SoftRAID driver is not loading. MacOS is (helpfully) offering to initialize the disks with Disk Utility) Which is normal, when macOS does not know what to do with a disk.

Did you do this?
https://support.apple.com/en-lk/guide/mac-help/mchl768f7291/mac
Select reduced security and enable this:
Select the “Allow user management of kernel extensions from identified developers” checkbox to allow installation of software that uses legacy kernel extensions.

When you did the driver update, did you go to System Preferences / Security to "Allow" OWC as an identified developer?

After enabling third party extensions, reinstall the SoftRAID driver, and go to System Preferences / Security to "Allow" OWC as an identified developer

ReplyQuote
Posted : 09/12/2021 4:55 pm
(@sleepyninja)
New Member

I just did all that from above. Now I am getting an error from softraid, saying then it needs to be restarted. I then restart it and it still does not mount. 

Screen Shot 2021 12 10 at 1.58.10 PM
ReplyQuote
Topic starter Posted : 10/12/2021 4:01 pm
(@softraid-support)
Member Admin

@sleepyninja 

This is kind of a permissions error. Follow the below to remove all installed SoftRAID components, then SoftRAID should launch. Then it will want to install the driver, and do so, as per below;

How to manually Remove/uninstall the SoftRAID driver and components:

Paste each command line below into the terminal application. You will need your normal admin password for some steps.

Delete the SoftRAID driver:
sudo rm -r /Library/Extensions/SoftRAID.kext
sudo touch /Library/Extensions
sudo kextcache -fu /

Now, Restart your computer

Remove the daemon and SoftRAID Monitor:
sudo rm /Library/LaunchDaemons/com.softraid.softraidd.plist
sudo rm /Library/LaunchAgents/com.softraid.SoftRAIDMonitor.plist

Remove the SoftRAID application support directory:
sudo rm -r /Library/Application\ Support/SoftRAID

Remove all the SoftRAID preferences:
defaults delete com.softraid.SoftRAID

Remove preference files
sudo rm -r com.softraid.com

reset the extensions caches:
sudo kmutil clear-staging
sudo kextcache -i /

Restart the Mac. SoftRAID volumes will no longer mount on the desktop, but that is temporary, until you reinstall the driver.

When you run SoftRAID to install the driver, do not immediately restart. wait until the dialog box pops up to go to System Preferences/Security. "Allow" OWC as an Identified developer, now restart later when you quit System Preference, go to SoftRAID and restart.

 

 

ReplyQuote
Posted : 10/12/2021 4:17 pm
(@sleepyninja)
New Member

thanks!

I did this, then I initialized the disks again.

Then built a new directory. Now It loads with no errors.

 

Thanks!

 

ReplyQuote
Topic starter Posted : 10/12/2021 5:02 pm
Share:
close
open