Softraid Driver Upd...
 
Notifications
Clear all

Softraid Driver Update Freezing Catalina on Reboot

(@jdouglass)
Trusted Member Customer

As the title says I'm having issues with Softraid freezing my Mac upon reboot immediately after upgrading. This is actually the second time its happened. I'm currently using Softraid 5.8.4 and was asked earlier to update to I believe 6.0.1-which I did. Update went through ok but upon reboot the system displays the apple logo and just hangs. I cannot boot into safe mode and the only thing I can do to remedy it is to restore from my Time Machine with the 5.8.4 driver version.

 

Mac Pro 2019

Catalina 10.15.7

Softraid 5.8.4

Quote
Topic starter Posted : 05/04/2021 2:48 am
(@softraid-support)
Member Admin

Please attach a SoftRAID Tech Support file, so I can look.

ReplyQuote
Posted : 05/04/2021 9:36 am
(@jdouglass)
Trusted Member Customer
ReplyQuote
Topic starter Posted : 05/04/2021 7:55 pm
(@steve223)
Estimable Member Customer
Posted by: @jdouglass

As the title says I'm having issues with Softraid freezing my Mac upon reboot immediately after upgrading. This is actually the second time its happened. I'm currently using Softraid 5.8.4 and was asked earlier to update to I believe 6.0.1-which I did. Update went through ok but upon reboot the system displays the apple logo and just hangs. I cannot boot into safe mode and the only thing I can do to remedy it is to restore from my Time Machine with the 5.8.4 driver version.

 

Mac Pro 2019

Catalina 10.15.7

Softraid 5.8.4

Soft Raid 5.8x has caused havoc on my system for many month with Catalina 10.15.7. I updated two days ago to 6.0.1 and magically all issues seem to be resolved even the ones Soft Raid blamed on Apple (only 48 hours in but before that my Mac would restart itself at least once a day with a Kernel Panic and SoftRaid on top of the list. Buggy as not fit for any production environment IMO.

 

This post was modified 2 years ago by steve223
ReplyQuote
Posted : 06/04/2021 12:11 am
(@softraid-support)
Member Admin

@jdouglass

How are the disks connected to your Mac? Are these on a PCI card? Which one?

I cannot see what is going on, as you had to uninstall, etc, so there is no log entries, or crash logs I can investigate. (not your fault)

Maybe we can do this upgrade in two steps. Convert your volume to Apple format. Upgrade SoftRAID to 6.0.1. All should be well.

make sure you "Allow" OWC when prompted. I would next connect any device, even a thumbdrive, to the cmputer and initialize with SoftRAID and create a volume so you know the driver is loading OK (not blocked by macOS, etc)

Backup at this point, just to be certain, based on your past experience. (another idea is create a second startup volume, if you don't know how to create a container with a new boot volume inside, let me know, I can give instructions)

Then convert your volume to SoftRAID.

 

 

ReplyQuote
Posted : 06/04/2021 2:05 am
(@softraid-support)
Member Admin

@steve223

Steve: Note that jdouglass is not having problems with Catalina, but with upgrading the driver to 6.0.1. I hope your system stays stable, but this is a different problem altogether.

ReplyQuote
Posted : 06/04/2021 2:07 am
steve223 liked
(@jdouglass)
Trusted Member Customer

@softraid-support I have an Amfeltec pci-e card with four WD Black nvme blades.

 

I figured with my time machine restore that the log wouldn't give you anything valuable to pinpoint the issue.

 

As far as the convert/upgrade-I'll probably wait a bit until I have some time and can take a few hours to do it in case I need to restore my system again.

 

Thanks for the feedback 🤘🏻

ReplyQuote
Topic starter Posted : 06/04/2021 2:34 am
(@softraid-support)
Member Admin

@jdouglass

While the Amfeltec should not make a difference, I have not tested one. Maybe give this a try over the weekend or so.

ReplyQuote
Posted : 06/04/2021 2:37 am
Share:
close
open