SoftRAID not findin...
 
Notifications
Clear all

SoftRAID not finding ALL USB drives for Raid on 2019 Mac Pro under MacOS Catalina

(@ppoulos)
New Member Customer

I have recently purchased a 2019 Mac Pro to replace my aging late 2013 Mac Pro. Before I migrated the startup volume from one Mac Pro to the other I upgraded the OS to Catalina on my late 2013 Mac Pro and corrected any minor problems i found with my installed software. SoftRAID worked perfectly fine on the older late 2013 Mac Pro.

When I migrated the startup volume to the 2019 Mac Pro I noticed that SoftRAID was not consistently finding both 8TB USB drives used to completed a RAID 0 volume. In addition to the standard Apple Card with two USB 3.0 ports I added a Sonnet Allegro Pro Type A USB 3.2 PCIe with four USB 3.2 ports. I have may older devices connected to the USB ports, and they are easily found and accessed. And even though the two USB Hard Drives spin up when connected directly to the ports on my Mac Pro (not through a USB hub) SoftRAID fails to find both drives consistently (the Software finds usually one of the drives). I have changed out the USB cables, and tried connecting them to different combinations of the 6 ports without a change in behavior. It is puzzling to me why SoftRAID running under Catalina on the late 2013 Mac Pro had no problems finding the USB drives, but on the new 2019 Mac Pro only intermittently finds the drives without any obvious pattern. Any suggestions to solve this problem?

Quote
Topic starter Posted : 21/12/2019 9:10 pm
(@softraid-support)
Member Admin

This appears very much to be a hardware problem.

The easy way to confirm is if the disk is not in the SoftRAID disks column.
Then run Disk Utility and confirm that the disk is not appearing there also.
(you can also use the terminal and "diskutil list" which lists all disks, and it is probably not there either.)

If this is the case, Sonnet may need to issue a firmware updater. I know we are just getting our Mac Pro's, that is likely with Sonnet also, so it may take them some time to test this, find the root cause, and issue a firmware update.

ReplyQuote
Posted : 22/12/2019 9:40 am
Share:
close
open