Need help getting d...
 
Notifications
Clear all

Need help getting driver to load RAID on my iMac

(@doubleg)
Active Member

Hello, I recently had to renistall Big Sur on my 2017 iMac and I cannot get my Thunderbay to mount!  I am able to only get the raid to mount if I do a complete wipe of Softraid driver using the following instructions but once I restart the computer the raid no longer mounts and I have to go through the whole process again to get it to mount.  Please help!

These are the commands I am running every time I start up my iMac:

Delete the SoftRAID driver:
sudo rm -r /Library/Extensions/SoftRAID.kext
sudo touch /Library/Extensions
sudo kextcache -fu /

Now, Restart your computer

Remove the daemon and SoftRAID Monitor:
sudo rm /Library/LaunchDaemons/com.softraid.softraidd.plist
sudo rm /Library/LaunchAgents/com.softraid.SoftRAIDMonitor.plist

Remove the SoftRAID application support directory:
sudo rm -r /Library/Application\ Support/SoftRAID

Remove all the SoftRAID preferences:
defaults delete com.softraid.SoftRAID

Remove preference files
sudo rm -r com.softraid.com

reset the extensions caches:
sudo kmutil clear-staging
sudo kextcache -i /

Restart the Mac. SoftRAID volumes will no longer mount on the desktop, but that is temporary, until you reinstall the driver.

When you run SoftRAID to install the driver, do not immediately restart. wait until the dialog box pops up to go to System Preferences/Security. "Allow" OWC as an Identified developer, now restart, (you have to maneuver around a couple different restart buttons SoftRAID and macOS)

Quote
Topic starter Posted : 01/10/2021 5:11 pm
(@softraid-support)
Member Admin

That solution is "one time", only when the SoftRAID application generates an error that "a part of the SoftRAID Monitor has failed".

When your driver is not loading, this may be a simpler issue. Assuming you have Allowed OWC as an identified developer, If you paste this command into the terminal at restart, does your volume mount?

sudo kmutil load -p /Library/Extensions/SoftRAID.kext

ReplyQuote
Posted : 01/10/2021 10:03 pm
(@doubleg)
Active Member

@softraid-support yes, running that command did load the driver and mounted the RAID.  That being said, once I restarted the machine I had to do it again.  Something is definitely not allowing the driver to load.  Do you have any further suggestions?

ReplyQuote
Topic starter Posted : 02/10/2021 8:36 pm
(@softraid-support)
Member Admin

@doubleg

That is the bug.

We are adding a workaround (essentially entering this terminal command at startup by the SoftRAID Monitor) in SoftRAID 6.1 which is due soon.

Apple committed to fixing it, but it has not been fixed yet as of 11.6.

Note:

The "up" key in terminal will show prior commands, so next time you need to manually load SoftRAID, just hit the up arrow in the terminal window, and this command will be available without having to type it.

ReplyQuote
Posted : 02/10/2021 8:47 pm
(@matt-von-b)
New Member

For me, macOS Big Sur 11.6 update made the extensions/drivers stop loading.

Manually loading the SoftRAID driver worked for me:
sudo kmutil load -p /Library/Extensions/globalSAN.kext
Of course just temporarily until next restart.

Today, the final solution came somewhat unexpectedly:
In Parallels, I've switched from Apple Hypervisor to Parallels Hypervisor (needing nested virt.).
This made the system ask me if I allow the use of their specific extension, by prompting for this Parallels extension in the security settings.
In the end, a message appeared that they rebuild the extensions cache now, and forced a system restart right after this.

Thanks for your extensive uninstall/reinstall/cache flush solutions here, but it was way less painful, meaning:
- No reinstall of SoftRAID drivers or any single of the other many drivers was needed.
- No reduced security for legacy kernel extensions was needed etc.

After extensions cache was rebuilt (in this case by Parallels), everything worked like a charm again. Every boot!

At least it seems to me that Parallels was able to fix it without the help of Apple.
Best wishes for a similar permanent solution here.

ReplyQuote
Posted : 03/10/2021 2:15 pm
Share:
close
open