SR 6.0.5 after usin...
 
Notifications
Clear all

SR 6.0.5 after using Parallels can't install the Softraid-Driver - HELP!

(@ray-engel)
New Member

Hello,

I am on Big Sur 11.5 - with Softraid 6.0.5 on a MacPro with a Accelsior4M2.

Yesterday I install a new Parallels.APP and my Accelsior4M2 is vanished!

As I understand the Parallels made a lot of trouble... so I remove the Parallels.APP complete and try to re-up the Accelsior-Drive without success. :-(

When I open the Softraid.APP it says: Failure - and I can only quit the Software. No Driver comes up - Nothing.

So I try out the:

sudo kmutil load -p /Library/Extensions/SoftRAID.kext

it wakes for me and the Accelsior-Drive comes up again on the Desktop.

But after a reboot I had the same Problem - no driver to install and the Softraid can only quit.

After the sudo kmutil load... the Accelsior comes up again.

##

After all this trouble I re-Install a fresh Big Sur over the old one and the Accelsior-Drive comes up automatically from now on.

so good so far... But the Sotraid.APP quits always after opening. I try to download a fresh Softraid to install them - but always the same: quit after opening and no driver to install comes up. HOW can I complete uninstall the Softraid.APP with all the drivers? I try every Terminal commands to delete them from this Forum but without success.

by the way - my csrutil is disabled

Ray. E.

(sorry for my School-English)

Quote
Topic starter Posted : 23/07/2021 2:40 am
(@softraid-support)
Member Admin

the driver is installed, but not loading, which is why the kmutil load command works. this is the Big Sur issue we are hoping gets fixed.

Which is closer to the message you are getting when you launch SoftRAID:

An internal part of the SoftRAID application failed...

An internal part of the SoftRAID Monitor failed...

It may help me solve this problem for you.

ReplyQuote
Posted : 23/07/2021 10:41 am
(@ray-engel)
New Member
Posted by: @softraid-support

An internal part of the SoftRAID application failed...

this is the closer Message... but in the security section under Accessibility or Full Disk Access is no Softraid-Monitor! 

But I swear I saw that one before! 

Thanks for your quick infos.

Ray

ReplyQuote
Topic starter Posted : 23/07/2021 11:28 am
(@softraid-support)
Member Admin

@ray-engel

In Full Disk Access, only the SoftRAID application needs to be there, so the app can query the raw disks. If SoftRAID app is not listed, please add it.

But that should not cause the error you are getting. restart and test this, however and let me know.

ReplyQuote
Posted : 23/07/2021 11:41 am
(@ray-engel)
New Member

@softraid-support

Yes I am adding the Softraid.APP in the security section. 

But when I try to Install the Software I get this error message like in picture:

Bildschirmfoto 2021 07 23 um 18.58.55

Translation from German: an internal part of the Softraid monitor is not working properly.
Please exit Softraid and start it again.

I have tried this several times - but it always gives this one message.

 

Ray

ReplyQuote
Topic starter Posted : 23/07/2021 12:12 pm
(@softraid-support)
Member Admin

See what happens if you manually uninstall all the SoftRAID components via terminal. Can you launch the app now?

Paste each command line below into the terminal application. You will need your normal admin password for some steps.

Delete the SoftRAID driver:
sudo rm -r /Library/Extensions/SoftRAID.kext
sudo touch /Library/Extensions
sudo kextcache -fu /

Now, Restart your computer

Remove the daemon and SoftRAID Monitor:
sudo rm /Library/LaunchDaemons/com.softraid.softraidd.plist
sudo rm /Library/LaunchAgents/com.softraid.SoftRAIDMonitor.plist

Remove the SoftRAID application support directory:
sudo rm -r /Library/Application\ Support/SoftRAID

Remove all the SoftRAID preferences:
defaults delete com.softraid.SoftRAID

Remove preference files
sudo rm -r com.softraid.com

reset the extensions caches:
sudo kmutil clear-staging
sudo kextcache -i /

Restart the Mac. SoftRAID volumes will no longer mount on the desktop, but that is temporary, until you reinstall the driver.

When you run SoftRAID to install the driver, do not immediately restart. wait until the dialog box pops up to go to System Preferences/Security. "Allow" OWC as an Identified developer, now restart, (you have to maneuver around a couple different restart buttons SoftRAID and macOS)

 

ReplyQuote
Posted : 23/07/2021 5:06 pm
(@ray-engel)
New Member

@softraid-support

sorry for not getting back to you until now, but the OWC is my video-scratch SSD

and it was still filled with a project I had to finish first.

I ran all the commands the same way through the terminal and it worked!

Just entered the serial number and I was done.

MANY Thanks!

I was able to get the driver back in now and everything works fine.

greetings
Ray

This post was modified 2 months ago 2 times by ray.engel
ReplyQuote
Topic starter Posted : 27/07/2021 1:41 am
Share:
close
open