Internal Part Error...
 
Notifications
Clear all

Internal Part Error Rears Its Head AGAIN

(@marclw)
Active Member

Hi, everyone! Softraid 6.0.5., the application, has been working well with my 2019 MacBook Pro 16" top of the line machine running the most recent MacOS system, 11.4, up until a few days ago. All of the sudden I have started getting those "An internal part of the Softraid Monitor has stopped functioning properly." This happened once before with a different Big Sur build, and I was able to solve it. This time, no dice. I simply can't get it to run anymore. I've deinstalled it. Reinstalled it. Shut it all down. Started it all up, to no avail. I don't see anything in the Console, but I'm not a coder...... Any help would be appreciated. Thanks in advance! By the way, I checked the internet and could not find an answer.

Marc

Quote
Topic starter Posted : 14/06/2021 10:20 am
(@softraid-support)
Member Admin

There is no solution yet that is consistent, I am waiting for a debug version of SoftRAID to send to some users.

Did you install any software since last restart?

is there still a SoftRAID icon in the menu bar?

In the SoftRAID log you will see an error about the Monitor. Some process is either killing the Monitor, or blocking it from running.

 

ReplyQuote
Posted : 14/06/2021 11:46 am
(@softraid-support)
Member Admin

Here is an attempt to resolve the error where the error launching SoftRAID occurs, the SoftRAID Monitor failed.

What we are going to try is manually remove all SoftRAID components, as below.

Please let me know if this does or does not solve your issue. thanks

How to manually Remove/uninstall the SoftRAID driver and components:

Paste each command line below into the terminal application. You will need your normal admin password for some steps.

Delete the SoftRAID driver:
sudo rm -r /Library/Extensions/SoftRAID.kext
sudo touch /Library/Extensions
sudo kextcache -fu /

Now, Restart your computer

Remove the daemon and SoftRAID Monitor:
sudo rm /Library/LaunchDaemons/com.softraid.softraidd.plist
sudo rm /Library/LaunchAgents/com.softraid.SoftRAIDMonitor.plist

Remove the SoftRAID application support directory:
sudo rm -r /Library/Application\ Support/SoftRAID

Remove all the SoftRAID preferences:
defaults delete com.softraid.SoftRAID

reset the extensions caches:
sudo kextcache -i /
sudo kextcache -system-caches

Restart the Mac. SoftRAID volumes will no longer mount on the desktop, but that is temporary, until you reinstall the driver.

When you run SoftRAID to install the driver, do not immediately restart. wait until the dialog box pops up to go to System Preferences/Security. "Allow" OWC as an Identified developer, now restart, (you have to maneuver around a couple different restart buttons SoftRAID and macOS)

 

ReplyQuote
Posted : 23/06/2021 10:17 am
(@marclw)
Active Member

@softraid-support I'm going to try this shortly. Update: I am still experiencing this error. My home files are on my RAID. Now, my System/boot drive no longer find the RAID drive's "marclw" user folder that I pointed it to. When I boot the system pointing it to a copy of that user folder on another non-RAID external drive, everything boots perfectly. It sees the drive and the user folder. And, I can see the icon for my RAID drive on the desktop. Also, if I boot in ROOT, point the drive to the "marclw" user on the RAID user folder and then log out of the root user and back into the marclw user, everything works fine. In any event, the I still get the same error when trying to open the softraid application. I also tried doing all this under safe boot; no joy. I think that if I can get the application to run, I'll be able to reinstall the softraid driver and that would solve the issue, at least with being able to use the RAID. Thoughts??

ReplyQuote
Topic starter Posted : 18/07/2021 12:32 pm
(@softraid-support)
Member Admin

@marclw

Seems like this is the bug where in Big Sur it is not loading the SoftRAID driver at startup.

Because you have the home folder on the RAID volume, that is causing the system to panic. Does that fit your symptoms?

What if you have your home folder on your boot volume, but replace the Documents, Desktop/Downloads, etc folders with an alias to the RAID volume, so you can manually load the driver after startup. Does that work?

ReplyQuote
Posted : 18/07/2021 8:12 pm
Share:
close
open