Apple M1, SoftRAId ...
 
Notifications
Clear all

Apple M1, SoftRAId and Big Sur security: What I learned

(@mtsandersen)
New Member Customer

I finally got my SoftRAID volumes working after hours of trying, and wanted to make some comments on my experience.

I recently got an M1 Mac Mini, so fresh install of SoftRaid 6.05 on OSX 11.3, and I ran into the SoftRaid driver issue. I came from a 2013 27" iMac with OS10.11 (El Capitan), as I wanted to maintain a certain program that stops working in later versions, so all the later security measures are new to me. Basically, my SoftRaid drives (connected via an OWC hub) would be recognised, but wouldn't mount, like so many have encountered. I tried uninstalling, rebooting, and reinstalling, without success. There was something about Allowing OWC mentioned online, but the install never popped the system preferences open, and I didn't see an Allow button. There was a dialog that appeared briefly I simply clicked OK on without reading. That was important clue as it turned out.

After much reading, trying to use Cmd+R on restart a few times before realising it didn't work on this version, then finding the Apple page on shutting down and restarting while holding the power button, I got into the Recovery mode, entered my credentials as described by Apple here, clicked a button to show the Utilities menu, got to the Startup Security Utility via the Utility menu at the top, and set Security to Reduced Security, and enabled the option “Allow user management of kernel extensions from identified developers”. Later I found a thread here where it gave those steps.

One thing to note here: It said it was going to enable the changes, and the spinning wheel started. It took some time, so went and did something. It was still going when I came back, which is too long; I then noticed I had an SSD plugged into the OWC dock, and it was blinking furiously. So I unplugged it, and a message came up straight away that the changes had failed. I then re-enabled them as above, and this time it worked without delay.

The lesson is: Remember to unplug or turn off *all* external drives.

After the restart, I removed SoftRAID and re-installed. I paid closer attention to any dialog boxes this time. I then noticed that one of the dialog boxes that flash up briefly before being covered by a SoftRaid dialog saying driver installation successful, was a system notice saying "System extensions blocked: A program tried to load new extensions signed by 'Other World Computing' that need to be updated by the developer". The button options are 'Learn More' or 'OK'. Learn More takes you to an Apple webpage describing the issue and how to Allow them, OK just makes the dialog go away. 

I had a look at System Preferences: Security & Privacy. Throughout my attempts to get it working, I had it on the Privacy tab, to give SoftRaid full disk access, but couldn't find anything else to enable, and nothing to Allow. 

And this is the next lesson: All the forum posts mentions the Security & Privacy preferences, and mention clicking Allow for OWC, but none mention it is under the General tab. And so I never saw it, because I was looking under the wrong tab. It is not a pop-up dialog, it is a contextual item that appear under the General tab at the bottom. Having come straight from OSX 10.11, that never occurred to me.

After that, it worked fine. All these new security features like Secure Boot and System Integrity Protection are new to me. If there's something the SoftRAID installer can do to make it more obvious *EXACTLY* what you need to do after to Allow the driver, and perhaps open the right pane after you click OK on the instructions dialog, that would be good. I don't know if I needed to go into the Safe Boot and reduce the Security level after all that, but it works now - for now, at least. I haven't restarted yet.

Quote
Topic starter Posted : 14/06/2021 8:36 am
(@softraid-support)
Member Admin

Your description is accurate. We are going to be addressing user interface changes as soon as we (and I guess Apple) stabilize how drivers get installed.

If you go to System Preferences/Security immediately (within 30 minutes) of your restart, the option will be there. Same if you "reinstall SoftRAID driver".

Best practice is not click "restart" in SoftRAID until you set System Preferences. But that dialog box is often delayed and easy to click "OK" instead of getting the user to System Preferences/Security. So it is very easy to go wrong there.

 

thanks for the feedback, we are working on how to make this easiest on users.

ReplyQuote
Posted : 14/06/2021 11:53 am
Share:
close
open