Recurring Kernel Pa...
 
Notifications
Clear all

Recurring Kernel Panics

(@crumpldfoil)
Active Member Customer

Hi there,

Posting here purely because the panic is referencing the softraid kext, but my 2017 iMac running Big Sur 11.2.3 keeps throwing a fit. Did a fresh install of macOS on Saturday in hopes of making them stop (they were happening daily). Worked like a charm until around 2am this morning when it was sitting idle and restarted. 

What additional details might I be able to provide that could help diagnose? Or is there maybe something in the panic report or support report that I'm missing that points to a different culprit?

Thanks in advance for any assistance you might be able to provide. I'm kinda at my wits end with this.

panic(cpu 1 caller 0xffffff801d164a25): userspace watchdog timeout: no successful checkins from com.apple.logd in 120 seconds
service returned not alive with context : unresponsive dispatch queue(s): com.apple.firehose.io-wl 
service: com.apple.logd, total successful checkins since wake (319496 seconds ago): 31938, last successful checkin: 120 seconds ago
service: com.apple.WindowServer, total successful checkins since wake (319496 seconds ago): 31950, last successful checkin: 0 seconds ago

Backtrace (CPU 1), Frame : Return Address
0xffffffa0f0a93670 : 0xffffff8019ebab4d 
0xffffffa0f0a936c0 : 0xffffff8019ffd7e3 
0xffffffa0f0a93700 : 0xffffff8019fede1a 
0xffffffa0f0a93750 : 0xffffff8019e5fa2f 
0xffffffa0f0a93770 : 0xffffff8019eba3ed 
0xffffffa0f0a93890 : 0xffffff8019eba6d8 
0xffffffa0f0a93900 : 0xffffff801a6bf004 
0xffffffa0f0a93970 : 0xffffff801d164a25 
0xffffffa0f0a93980 : 0xffffff801d164678 
0xffffffa0f0a939a0 : 0xffffff801a64628e 
0xffffffa0f0a939f0 : 0xffffff801d163ab4 
0xffffffa0f0a93b20 : 0xffffff801a65045b 
0xffffffa0f0a93c80 : 0xffffff8019fa8e51 
0xffffffa0f0a93d90 : 0xffffff8019ec0147 
0xffffffa0f0a93e00 : 0xffffff8019e96905 
0xffffffa0f0a93e60 : 0xffffff8019eae062 
0xffffffa0f0a93ef0 : 0xffffff8019fd1fc3 
0xffffffa0f0a93fa0 : 0xffffff8019e60216 
      Kernel Extensions in backtrace:
         com.apple.driver.watchdog(1.0)[2C1307C5-FD71-3802-8D68-A67DB24BCB4A]@0xffffff801d163000->0xffffff801d164fff

Process name corresponding to current thread: watchdogd

Mac OS version:
20D91

Kernel version:
Darwin Kernel Version 20.3.0: Thu Jan 21 0006 PST 2021; root:xnu-7195.81.3~1/RELEASE_X86_64
Kernel UUID: C86236B2-4976-3542-80CA-74A6B8B4BA03
KernelCache slide: 0x0000000019c00000
KernelCache base:  0xffffff8019e00000
Kernel slide:      0x0000000019c10000
Kernel text base:  0xffffff8019e10000
__HIB  text base: 0xffffff8019d00000
System model name: iMac18,3 (Mac-BE088AF8C5EB4FA2)
System shutdown begun: NO
Panic diags file available: YES (0x0)
Hibernation exit count: 0

System uptime in nanoseconds: 320854977582119
Last Sleep:           absolute           base_tsc          base_nano
  Uptime  : 0x000123d0def696a8
  Sleep   : 0x0000013822ec130d 0x000000009cbe9980 0x0000012872c738f9
  Wake    : 0x000001382757493c 0x000000009caec870 0x0000013826424f67
last started kext at 35077200820: >!AHIDKeyboard	223 (addr 0xffffff801b292000, size 16384)
loaded kexts:
com.softraid.driver.SoftRAID	6.0.1
>!ATopCaseHIDEventDriver	4030.5
>AudioAUUC	1.70
>!APlatformEnabler	2.7.0d0
>AGPM	119
>X86PlatformShim	1.0.0
@fileutil	20.036.15
@filesystems.autofs	3.0
>!AUpstreamUserClient	3.6.8
@kext.AMDFramebuffer	4.0.2
@kext.AMDRadeonServiceManager	4.0.2
@kext.AMDRadeonX4000	4.0.2
>!AGraphicsDevicePolicy	6.2.2
@AGDCPluginDisplayMetrics	6.2.2
>pmtelemetry	1
>LuaHardwareAccess	1.0.16
|IOUserEthernet	1.0.1
>usb.!UUserHCI	1
|IO!BSerialManager	8.0.3d9
@Dont_Steal_Mac_OS_X	7.0.0
>!AHV	1
>!ADiskImages2	1
>!AHDAHardwareConfigDriver	283.15
>!A!ISlowAdaptiveClocking	4.0.0
>AGDCBacklightControl	6.2.2
>!AHDA	283.15
>!A!IPCHPMC	2.0.1
>!AGFXHDA	100.1.431
@kext.AMD9500!C	4.0.2
|Broadcom!B20703USBTransport	8.0.3d9
>!AThunderboltIP	4.0.3
>ACPI_SMC_PlatformPlugin	1.0.0
>!AFIVRDriver	4.1.0
>eficheck	1
>!ASMCLMU	212
>!A!IKBLGraphics	16.0.1
>!A!IKBLGraphicsFramebuffer	16.0.1
>!ABacklight	180.3
>!AMCCSControl	1.14
|SCSITaskUserClient	436.40.6
|IO!BUSBDFU	8.0.3d9
>!AFileSystemDriver	3.0.1
@filesystems.tmpfs	1
@filesystems.hfs.kext	556.60.1
@BootCache	40
@!AFSCompression.!AFSCompressionTypeZlib	1.0.0
@!AFSCompression.!AFSCompressionTypeDataless	1.0.0d1
@filesystems.apfs	1677.81.1
|!ABCM5701Ethernet	11.0.0
>!ASDXC	1.9.0
>AirPort.BrcmNIC	1400.1.1
>!AAHCIPort	346
@private.KextAudit	1.0
>!AACPIButtons	6.1
>!ARTC	2.0
>!ASMBIOS	2.1
>!AACPIEC	6.1
>!AAPIC	1.7
@!ASystemPolicy	2.0.0
@nke.applicationfirewall	310
|IOKitRegistryCompatibility	1
|EndpointSecurity	1
>!AHIDKeyboard	223
@plugin.IOAVBDiscoveryPlugin	930.1
>!AActuatorDriver	4400.28
>!AMultitouchDriver	4400.28
>!AInputDeviceSupport	4400.35
>!AHS!BDriver	4030.5
>IO!BHIDDriver	8.0.3d9
>!UAudio	401.4
@kext.triggers	1.0
@kext.AMDRadeonX4200HWLibs	1.0
@kext.AMDRadeonX4000HWServices	4.0.2
>!AGraphicsControl	6.2.2
|IOSerial!F	11
|IOAVB!F	930.1
@plugin.IOgPTPPlugin	900.11
|IOEthernetAVB!C	1.1.0
@!AGPUWrangler	6.2.2
|IOSlowAdaptiveClocking!F	1.0.0
>DspFuncLib	283.15
@kext.OSvKernDSPLib	529
@kext.AMDSupport	4.0.2
|Broadcom!BHost!CUSBTransport	8.0.3d9
|IO!BHost!CUSBTransport	8.0.3d9
|IO!BHost!CTransport	8.0.3d9
>!AThunderboltEDMSink	5.0.3
>IOPlatformPluginLegacy	1.0.0
>X86PlatformPlugin	1.0.0
>IOPlatformPlugin!F	6.0.0d8
>!ASMBusPCI	1.0.14d1
>!AHDA!C	283.15
|IOHDA!F	283.15
|IOAudio!F	300.6.1
@vecLib.kext	1.2.0
|IOAccelerator!F2	439.52
@!AGraphicsDeviceControl	6.2.2
>!ABacklightExpert	1.1.0
|IONDRVSupport	585
|IOGraphics!F	585
>!ASMBus!C	1.0.18d1
>usb.!UHub	1.2
>usb.IOUSBHostHIDDevice	1.2
>usb.cdc	5.0.0
>usb.networking	5.0.0
>usb.!UHostCompositeDevice	1.2
>!AThunderboltDPOutAdapter	8.1.4
>!AThunderboltDPInAdapter	8.1.4
>!AThunderboltDPAdapter!F	8.1.4
>!AThunderboltPCIUpAdapter	4.1.1
>!AThunderboltPCIDownAdapter	4.1.1
>!AHPM	3.4.4
>!A!ILpssI2C!C	3.0.60
>!A!ILpssDmac	3.0.60
>!ABSDKextStarter	3
|IOSurface	289.3
@filesystems.hfs.encodings.kext	1
>!AXsanScheme	3
|IOAHCIBlock!S	332
>!AThunderboltNHI	7.2.8
|IOThunderbolt!F	9.3.2
|IONVMe!F	2.1.0
|IO80211!F	1200.12.2b1
|IOSkywalk!F	1
>mDNSOffloadUserClient	1.0.1b8
>corecapture	1.0.4
>!A!ILpssI2C	3.0.60
>!A!ILpssGspi	3.0.60
|IOAHCI!F	294
>usb.!UXHCIPCI	1.2
>usb.!UXHCI	1.2
>usb.!UHostPacketFilter	1.0
|IOUSB!F	900.4.2
>!AEFINVRAM	2.1
>!AEFIRuntime	2.1
|IOSMBus!F	1.1
|IOHID!F	2.0.0
$!AImage4	3.0.0
|IOTimeSync!F	900.11
|IONetworking!F	3.4
>DiskImages	493.0.0
|IO!B!F	8.0.3d9
|IOReport!F	47
|IO!BPacketLogger	8.0.3d9
$quarantine	4
$sandbox	300.0
@kext.!AMatch	1.0.0d1
|CoreAnalytics!F	1
>!ASSE	1.0
>!AKeyStore	2
>!UTDM	511.60.2
|IOUSBMass!SDriver	184.40.6
|IOSCSIBlockCommandsDevice	436.40.6
|IO!S!F	2.1
|IOSCSIArchitectureModel!F	436.40.6
>!AMobileFileIntegrity	1.0.5
@kext.CoreTrust	1
>!AFDEKeyStore	28.30
>!AEffaceable!S	1.0
>!ACredentialManager	1.0
>KernelRelayHost	1
|IOUSBHost!F	1.2
>!UHostMergeProperties	1.2
>usb.!UCommon	1.0
>!ABusPower!C	1.0
>!ASEPManager	1.0.1
>IOSlaveProcessor	1
>!AACPIPlatform	6.1
>!ASMC	3.1.9
|IOPCI!F	2.9
|IOACPI!F	1.4
>watchdog	1
@kec.pthread	1
@kec.corecrypto	11.1
@kec.Libm	1

 

Quote
Topic starter Posted : 09/04/2021 9:02 am
(@softraid-support)
Member Admin

This watchdog bug is a kernel bug, but generally only affects users with >12 disks, at shutdown. the disk cache cannot be flushed before watchdog times out and causes a crash.

Is this happening during use, or when restarting/shutting down?

If so, what if you unmount your volumes first, then shut down?

ReplyQuote
Posted : 09/04/2021 1:28 pm
(@crumpldfoil)
Active Member Customer

90% of the time it has been happening overnight, and I wake my computer for the first time during the day to a "Your computer has restarted..." box.

I saw another post with a very similar panic mention disabling spotlight on the volume, so I gave that a shot since it definitely isn't necessary for my use case. No panics since, but it has only been a couple of days.

Over the weekend a new situation has popped up that could be related, where moving large (<10GB) files to the volume was causing very strange hangs where everything would become unresponsive (Force Quit window frozen, app switcher frozen on screen, Activity monitor unresponsive, etc.), there would be no disk activity, and I'd end up having to go the nuclear route and hold down the power button to shut it down. Happened twice. 

Is there some sort of diagnostic I should run to identify if this is some sort of hardware issue? I feel like this is strange behavior for a fresh install of macOS, particularly the panics that I did the reinstall to get away from.

 

Thanks in advance!

ReplyQuote
Topic starter Posted : 12/04/2021 9:30 am
(@softraid-support)
Member Admin

@crumpldfoil

THe kernel panic is a "watchdog" panic, matching the kernel issue of taking too long for disks to respond, so the system panics. Let us know about spotlight, it should not be directly involved with this issue.

The hang could be either disk or memory related. What brands of RAM are in your iMac? What if you try with just the two 8GB DIMMS installed?

THe disks appear OK, but it is possible they are involved (or one of them)

Not sure how to test them, perhaps run a verify disk in the background of all the disks.

When you do this, run this command in a terminal window:

iostat -w 2 disk3 disk4 disk5 disk6

(whatever the disk number in SoftRAID's disk tile of that disk. (currently 3 4 5 6)

This will print out in the window the MB/s of the disk. When it completes, you can scan through the window looking for periods of no activity. Might help you identify if there is a disk that is acting up.

 

ReplyQuote
Posted : 12/04/2021 11:50 am
(@crumpldfoil)
Active Member Customer

Thanks again for the quick response!

RAM wise, the two 4GB DIMMs are factory, the two 8GB DIMMs are Adamanta brand and have worked well for the last few years. Nothing lasts forever I guess. 

I'll do as advised above, maybe something interesting will emerge from it. 

 

ReplyQuote
Topic starter Posted : 12/04/2021 12:28 pm
(@softraid-support)
Member Admin

@crumpldfoil

Its worth the test, it is not necessarily that the RAM is bad but there can be conflicts with Apple brand RAM in some cases.

 

SoftRAID being a disk driver pushes the System RAM profiler higher.

 

 

Its worth testing.

ReplyQuote
Posted : 12/04/2021 2:37 pm
Share:
close
open