Monterey SoftRAID B...
 
Notifications
Clear all

[Sticky] Monterey SoftRAID Beta testing

Page 3 / 7
(@softraid-support)
Member Admin

@zathras

Better is run this in terminal and see what is loading:

 

sudo kextstat -b com.softraid.driver.SoftRAID

ReplyQuote
Topic starter Posted : 25/09/2021 5:14 pm
(@joemikeb)
Trusted Member Customer

After weeks of happily using SoftRAID 6.1 b18 on Monterey 6.0 beta 6 and 7 I installed Monterey beta 8 and to my dismay,  the array once again refuses to mount. I haven't had time to go through all the trouble-shooting yet, that will have to wait until tomorrow. 

______________

Make intentional errors —
Otherwise the Great Spirit
realizes you have fulfilled
your purpose on earth.

— Navajo saying

ReplyQuote
Posted : 30/09/2021 7:00 pm
(@softraid-support)
Member Admin

@joemikeb

Did you make sure you did "Allow" OWC as an identified developer again? chances are, that was the issue.

ReplyQuote
Topic starter Posted : 30/09/2021 10:28 pm
(@joemikeb)
Trusted Member Customer

@softraid-support No I did not "allow OWC as a developer again" as the option never appeared in System Preferences > Security & Privacy. However, I used the Uninstall all softRAID components utility in 6.1 b18, rebooted, then reinstalled 6.1 b18, and reinstalled the driver and without rebooting or allowing OWC…. the array mounted and is working correctly. The only glitch is the SoftRAID app says the array is formatted APFS (case sensitive) which is incorrect, it is formatted APFS (or at least it was unless SoftRAID has changed the format).

______________

Make intentional errors —
Otherwise the Great Spirit
realizes you have fulfilled
your purpose on earth.

— Navajo saying

ReplyQuote
Posted : 02/10/2021 10:33 am
(@joemikeb)
Trusted Member Customer

@softraid-support 

Two minor annoyances remain at this point:

  1. The SoftRAID app reports the array as being formatted APFS (case sensitive) but unless SoftRAID has changed the format it is formatted APFS.
  2. The SoftRAID app is located in /Applications/SoftRAID 6.1 b18 folder but it does not appear in Launchpad nor can it be found in a Launchpad search. It can only be launched by navigating to the app in Finder.

______________

Make intentional errors —
Otherwise the Great Spirit
realizes you have fulfilled
your purpose on earth.

— Navajo saying

ReplyQuote
Posted : 02/10/2021 10:56 am
(@softraid-support)
Member Admin

@joemikeb

Did you let Time Machine use this as a backup? It changes volumes to Case Sensitive, if so. If not, send me a support file, so I can check.

ReplyQuote
Topic starter Posted : 02/10/2021 11:24 am
(@softraid-support)
Member Admin

@joemikeb

A: see my prior query about Time Machine

B: What is the expected behavior with Launchpad? (I never use it) Can you add it manually? It does not seem that this is a SoftRAID controlled behavior.

ReplyQuote
Topic starter Posted : 02/10/2021 11:26 am
(@joemikeb)
Trusted Member Customer

@softraid-support Yes the array is used for Time Machine. I knew that Time Machine required APFS, but I was unaware that it was APFS (case sensitive). Live and learn. 🙄 

______________

Make intentional errors —
Otherwise the Great Spirit
realizes you have fulfilled
your purpose on earth.

— Navajo saying

ReplyQuote
Posted : 02/10/2021 3:53 pm
(@joemikeb)
Trusted Member Customer

@softraid-support

Normally, applications placed in /Applications or ~/Applications are automatically picked up by Launchpad. It is a macOS function and beta18 is the only one app that was not been picked up. I am not sure what the exact mechanism is, but since the failure is unique to SoftRAID 6.1 b18 I thought I would let you know. I will also report the failure to Apple via the Software Feedback app. 

______________

Make intentional errors —
Otherwise the Great Spirit
realizes you have fulfilled
your purpose on earth.

— Navajo saying

ReplyQuote
Posted : 02/10/2021 4:03 pm
(@softraid-support)
Member Admin

@joemikeb

I will make a query about this. It may be that the release, notorized version will be loaded normally and beta versions are not added.

ReplyQuote
Topic starter Posted : 02/10/2021 5:19 pm
joemikeb liked
(@joemikeb)
Trusted Member Customer

@softraid-support

Scrub that! This afternoon I received a report that Time Machine had been unable to backup to the array in several days and when I checked, the array was not mounted and would not mount. Once again I used the SoftRAID 6.1 b18 utility to remove all SoftRAID components and manually removed SoftRAID from the /Applications folder, emptied the trash and rebooted. I installed SoftRAID 6.1 b18 once again, launched it, installed the helper, installed the driver and the SoftRAID app reported the array was ready for use. No reboot was required nor was permitting OWC as a developer. at this point At the same time, SoftRAID once again appeared among the Launchpad applications. The array mounted and showed as a Time Machine drive, but the Time Machine would not backup to the array until I removed it and added it back to Time Machine. since then it is performing perfectly.

If the array continues to mount and remains mounted, I have no further issues other than the bald spot where I have been scratching my head while trying to figure out what is going on.

Thanks for your patience.

______________

Make intentional errors —
Otherwise the Great Spirit
realizes you have fulfilled
your purpose on earth.

— Navajo saying

ReplyQuote
Posted : 03/10/2021 4:38 pm
(@mrfearless47)
Active Member Customer

Does SoftRaid 6.1 officially support Monterey Beta 8.  I've been holding off installing Monterey on one of my machines awaiting some word whether SoftRaid 6.1 supports the new OS.  I know Monterey is still in beta, but it will be released shortly.  Just checking to see whether it is safe to upgrade yet.

 

ReplyQuote
Posted : 05/10/2021 1:10 pm
(@softraid-support)
Member Admin

@mrfearless47

Because Monterey is still in beta and Apple is making changes, 6.1 is not for Monterey. So we could not announce support for Monterey and decided to have a specific release for Monterey, where are are confident of our ability to fully support Monterey.

we have 6.2 beta 1 available for Monterey beta testers.

ReplyQuote
Topic starter Posted : 05/10/2021 1:23 pm
(@mrfearless47)
Active Member Customer

Where is the beta?

ReplyQuote
Posted : 05/10/2021 2:39 pm
(@softraid-support)
Member Admin

@mrfearless47

http://www.softraid.com/sr_beta

ReplyQuote
Topic starter Posted : 05/10/2021 3:44 pm
Page 3 / 7
Share:
close
open