SoftRAID fails afte...
 
Notifications
Clear all

SoftRAID fails after MacOS Clean and install (erase and install) MacOS 12.3

Page 3 / 3
(@softraid-support)
Member Admin

@jonniemichael 

What is the terminal output of this command:

 

xattr /Library/Extensions/SoftRAID.kext

ReplyQuote
Posted : 27/03/2022 3:44 pm
(@jonniemichael)
Active Member

@softraid-support

"com.apple.quarantine"

ReplyQuote
Posted : 27/03/2022 3:46 pm
(@softraid-support)
Member Admin

@jonniemichael 

this means the SoftRAID driver is quarantined. I am going to send some instructions off line to clear this state, then lets try again. You can respond here, however.

ReplyQuote
Posted : 27/03/2022 6:42 pm
(@jonniemichael)
Active Member

@softraid-support this is what happens after i restart and type in that prompt into terminal

 
Jonnies-MBP:~ jonnie$ sudo kmutil load -p /Library/Extensions/SoftRAID.kext

Password:

Error Domain=KMErrorDomain Code=31 "Error occurred while building a collection: in /Library/StagedExtensions/Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext/KernelExports: in '/Library/StagedExtensions/Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext/KernelExports' missing __TEXT segment" UserInfo={NSLocalizedDescription=Error occurred while building a collection: in /Library/StagedExtensions/Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext/KernelExports: in '/Library/StagedExtensions/Library/Extensions/spl.kext/Contents/PlugIns/KernelExports.kext/KernelExports' missing __TEXT segment}

Jonnies-MBP:~ jonnie$ 

ReplyQuote
Posted : 27/03/2022 7:04 pm
(@softraid-support)
Member Admin

@jonniemichael 

You have some problem extensions loaded/installed.

Did you ever install openzfs on your system? that is what I think the spl.kext is from. It could also be from tuxera NTFS driver, or some other installation that uses it (like MacFuse).

 

Any of this ring a bell?

ReplyQuote
Posted : 27/03/2022 9:32 pm
(@jonniemichael)
Active Member

@softraid-support no sorry I havent heard of any of this

ReplyQuote
Posted : 27/03/2022 9:34 pm
(@softraid-support)
Member Admin

@jonniemichael 

Also, it appears you migrated data from an intel machine, you are better off not doing so, as macOS migration is brain dead and will also migrate intel-only drivers.

 

 

ReplyQuote
Posted : 27/03/2022 9:37 pm
(@softraid-support)
Member Admin

@jonniemichael 

at minimum, ZfS is installed in your system, however. That is not something that is for inexperienced users to install. I am surprised you did not remember installing it.

Are you able to do a clean install and not import old data? You may be better off. I don't know what else was imported and on a new architecture, it is better to start off clean.

ReplyQuote
Posted : 27/03/2022 9:39 pm
(@jonniemichael)
Active Member

by clean install you mean wipe the iOS?... I dont get why the drive was functioning properly until I upgraded the iOS

ReplyQuote
Posted : 27/03/2022 9:42 pm
(@softraid-support)
Member Admin

@jonniemichael 

I am recommending it, ARM is a totally different architecture and why carry the baggage of your old intel only extensions?

I don't know why the macOS upgrade did this, but it is apparently rejecting the presence of at least some of the old extensions.

I can post instructions on how to manually delete them, it takes some effort, but doable.

But consider a clean install.

 

ReplyQuote
Posted : 28/03/2022 1:55 am
Page 3 / 3
Share:
close
open