Mojave restart caus...
Clear all

Mojave restart causes OWC raid5 permissions to read only.

New Member Customer

Hi there, newbie here,

I have a macmini server running OSX Mojave 10.14.05 with a
OWC thunderbay in a raid 5 configuration, 4x6tb drives with 18TB useable.
Softraid XT 5.7.5

recently my raid started to play up and give drive errors.

I backed it up and replaced the questionable drive and rebuilt the raid with a new 6tb drive and rebuilt and validated the volume.

so far so good but each time I restart my server ( thankfully not too often ) it causes the 18tb raid volume to become read only.

I then end up repairing this with diskwarrior.

As disk warrior is on its last step of replacing directory,
this will often cause Softraid to say that the raid has degraded and failed until I recover the failed disks.

I've stopped validating then I recover because I've done it a few times recently and the drives are good.

I'm kinda' stuck in a loop and its a big waste of time.

Can anyone point me in the direction of a solution I haven't found anything in the forums where I have looked?

I am quite possibly forum blind and have just missed it, I apologise if this is the case.

Any help would be greatfully appreciated.


Topic starter Posted : 02/09/2019 12:11 pm
Member Admin

this is a strange problem.

I understand the Disk Warrior triggered errors. But it should not fail the RAID volume it should just trigger a couple disk errors on the disks, when it happens. (the disks are being asked to read from a non existent location, and SoftRAID is reporting them as disk errors, we are going to filter this out in a future release.)

Directory damage happening (on occasion), understand that also. That is HFS.

But every restart? Something strange is going on.

SoftRAID does not talk to the file system, so it is something in your system or hardware.

What all third party utilities are you running? On a server, these should be minimal.

Posted : 02/09/2019 12:56 pm
Eminent Member Customer

I don't know about your read-only issue. It sounds like some third-party extension generates those issues. Does the Macmini system uses a fast SSD disk?

There is one thing I like to add regarding DiskWarrior. DW destroys a SoftRAID HFS+ RAID volume on our 4 ThunderBay. Running DiskWarrior two times, SoftRAID shows disk failures + i/o errors for all 4 ssd disks (step 10 on finalising). After that SoftRAID get’s unresponsive and macOS freezes with beachball. As soon as you reboot macOS, all data have been lost. We replaced the ThunderBay as well as all SSDs, but DW still destroys the volume.

We haven't figured things out, yet. SoftRAID support told me it is probably happening because the drive is reporting it has a sector (probably at the end of the disk) that does not exist, such as the last sector). I really like DW. But for now I am not going to use Disk Warrior to prevent DW from destroying my SoftRAID RAID.

Posted : 02/09/2019 3:32 pm
Member Admin

Disk Warrior should not destroy data on a RAID volume. (even on SSD's)

I can try to reproduce this. I assume you had TRIM enabled? What brand SSD?

The "error" is a bug, but should not cause any data issues. I think I mentioned in this post or another, we are going to work around this.

But if there were a scenario where DW triggered data loss, we would be extremely interested in figuring it out and preventing it! Disk Warrior is the only option when volume directories get any damage.

Posted : 03/09/2019 1:35 am
Eminent Member Customer

@Brindood, sorry for abusing your question. However I think this DW issue is worth mentioning. It caused me so much trouble.

Yes, TRIM is enabled.
SSD brand: Samsung EVO 850 and Samsung EVO 860
I have replaced all Thunderbolt cables, SSDs and also tried a 2nd ThunderBay enclosure. I have certified all SSDs multiple times successfully.

You have to run DiskWarrior at least 2 times with any kind of data. Do not run DW on an empty SoftRAID volume. The issue occurs using the DW standalone app or the DW USB boot stick.
It some cases the RAID 4 volume get's unusable on DW's finalising step 10, which could cause immediate disk failures + i/o errors on all disks.

Sometimes DW rebuilt successfully the RAID 4 volume. Everything shows up fine until system reboot. Than macOS won’t boot while the ThunderBay is attached. At this point, you won't able to access your data anymore. SoftRAID permanently freezes with beachball.

Posted : 03/09/2019 6:27 am
Member Admin

I do not know of this issue nor can I replicate it.

I tried a couple ways (I do not have Samsung SSD's, so used blades)
Mojave 10.14.6
OWC M.2/4 Express (4 Samsung 970 Pro blades, 512GB)
or OWC Thunderblade (Four OWC blades, 512GB)
Mac Mini 2018
Disk Warrior 5.2
RAID 4 HFS volume.
Tried with TRIMforce enabled and disabled. (need to run trimforce to enable TRIM in macOS)

Copied 1TB data to the RAID 4 SoftRAID volume.
Ran Disk Warrior two times in succession.
No issues either way.

Am I missing something to replicate your problem?
If there is an issue, it seems like hardware. Did you check if your Samsung drives are Mac OS X compatible? (Some are not, you need to update firmware on those models)

If we can find a problem, we will work on it, but I have not ever seen this issue.

Posted : 03/09/2019 3:04 pm
Eminent Member Customer

Thanks, I was running Mac Sierra and DW 5.2. I don't think it's related to 10.12. According to Samsung both EVO models are mac compatible and are running the latest firmware. But, yes it could be a SSD incompatibility. Which SSD drives are fully supported?

Posted : 03/09/2019 4:25 pm
Member Admin

Any storage device that is direct connected and is reliable is supported by SoftRAID. SoftRAID does not care what the disk is. So all should be reliable. The problem is / was some Samsung drives were not fundamentally compatible with OSX. This is not SoftRAID, it is in Samsung's court. Once the drives are made/updated to be compatible, they will work fine with SoftRAID also.

I guess Samsung did not do adequate testing on that front. There is no "list" of such drives, as there should be zero models that do not work. Trying to track drives with firmware bugs would be a near impossible task.

Posted : 03/09/2019 5:25 pm
New Member Customer

Hi, thanks for the responses,

@howdytom no worries about the question hijack, I think we are having similar problems.

Trim has not been enabled, will enable as soon as I can

Ssd is sandisk ultra ll 480gb.

Quite a few third party utilities I’m afraid
I use this machine for work sometimes too.

This is what is generally running,

Security Spy
Softraid XT 5.7.5

The full list is on the attached screen grabs below.

As I say, I’ll try TRIM as soon as I can and see if that helps, but any info you can glean from my list of utilities would be appreciated and any other advice gratefully received.


Topic starter Posted : 04/09/2019 9:34 am
Member Admin

I would test by temporarily removing the 3 anti-virus apps.

These kinds of apps can be very intrusive and often cause more damage then they help.

If you have the time, watch this video from the renowned Jonathan Levin.

Yes, this is 3 years old, (with some great exploit examples) but the principals remain, the best security is being diligent with OS X updates. (Jonathan still teaches courses on Mac OS Security, his books are invaluable for programmers and system admins)

Apps that do not install extensions are not a problem. The only ones I would bother testing by disabling are the three mentioned. See if your problem remains. Let us know!

Posted : 04/09/2019 12:28 pm
Eminent Member Customer

@Brindood: Did you install Apps like Cleanmyac or MacKeeper? If so, try to completely unisntall them. Also, take look at unused Safari, Chrome, Firefox extension/addons.

Posted : 04/09/2019 3:18 pm