error number = 31 (...
 
Notifications
Clear all

error number = 31 (trying to create RAID5 with 4 x 4TB Drives)

(@r088ie)
New Member Customer

I have 4 x same model 4TB Toshiba discs and want to create a 4 disc RAID 5 (resulting in 12TB usable data)

I have the exact same issues as one user (dariusx) on your knowledge base and have tried all the same suggestion, fresh install, new user etc etc. consistently getting the same error even when trying to create a single volume on one disc.

All discs were previously fine and two were stripped via apple raid. I have certified all of them.

I have attached the results and pasted the log below. Spent all afternoon trying various options but im getting the same failed result each time. thanks.

Marker - 15 Aug 2016, 0716
Aug 15 0756 - SoftRAID Tool: Creating the RAID 5 volume named "Media" of size 10.9 TB with the following disks: disk3, SoftRAID ID: 06D735AAFBC65840, SATA bus 0, id 1 (Bay 1), disk2, SoftRAID ID: 06D735AAFBCB2680, SATA bus 0, id 2 (Bay 2), disk1, SoftRAID ID: 06D735AAFBD24300, SATA bus 0, id 3 (Bay 3), disk4, SoftRAID ID: 06D735AAFBD54C40, SATA bus 0, id 4 (Bay 4).
Aug 15 0706 - SoftRAID Tool: The volume create command for volume "Media" () failed with an error (error number = 31).

Quote
Topic starter Posted : 15/08/2016 2:21 am
(@softraid-support)
Member Admin

Lets try this beta version. We made one change that may help here.

https://softraid.com/sr_beta

Try it and let us know.

ReplyQuote
Posted : 15/08/2016 10:07 am
(@romainkedochim)
Active Member Customer

Hi all - Has this issue been fixed at all?

ReplyQuote
Posted : 03/03/2017 8:06 am
(@softraid-support)
Member Admin

In most cases yes. When this error happens, it is generally either a problem with the (OSX) HFS tool that creates volumes, or the drive is not responding soon enough when the file system is being created.

Check that the volume is given a BSD mount point in the volumes tile.

ReplyQuote
Posted : 04/03/2017 2:28 pm
(@webdweebmac-com)
New Member Customer

I am having the identical problem with a new Oyen Digital 5 bay Thunderbolt enclosure, loaded with 5 6TB HGST NAS drives (iMac, OSX Sierra 10.12.5). I'm using a 30 day evaluation copy of the app to confirm that the SW will work for me, but so far that is a big NO. None of the RAID options seem to work-I get the same error message with all of them. I can get Disk Utility to create a RAID 0 array, but SoftRAID fails when I try to convert it to a RAID 0 SoftRAID array. There are no disk identifiers because the disk creation does not finish, so I don't think I can use Terminal for any corrections. Thoughts?

ReplyQuote
Posted : 03/06/2017 5:10 pm
(@softraid-support)
Member Admin

First, try this:
"Uninstall SoftRAID" from Utilities menu.

Does this work?

If not, send us a SoftRAID tech support file at support at softraid.

ReplyQuote
Posted : 05/06/2017 10:47 am
(@santyman)
New Member Customer

Hello, im having the same problem, i have a thunderbay 4 raid5 edition, brand new, on a mac pro late 2013.
Everytime i try to create a volume it wont mount, saying that an error occurred creating the volume.
Softraid was unable to create a file system on this volume.
How do i fix this??

ReplyQuote
Posted : 14/04/2020 9:44 am
(@softraid-support)
Member Admin

Note: for those with a newer, T2 equipped machine, Secure Boot must also be disabled:
https://srforums.wpengine.com/pages/support/faq/faq_imacpro_secureboot.html

The mounting/initialization problem is the SoftRAID driver is prevented from loading by OS X security. You need to approve OWC as an "Identified Developer".

We created a PDF with instructions to help you resolve this problem:

https://srforums.wpengine.com/pages/support/5.8_Volumes_Not_Mounting.pdf

ReplyQuote
Posted : 14/04/2020 11:20 am
Share:
close
open