Thunderbays spin up...
 
Notifications
Clear all

Thunderbays spin up/down behavior - too frequent, long delay in loading data into finder

(@rustrx)
Active Member

Assuming this is the correct forum for this issue, if this winds up being a Mac OS / Monterey issue or a hardware issue with OWC, please let me know where I should go! 

Running an M1 Mac Mini with Monterey 12.0.1 , running Softraid XT 6.2. Attached on one thunderbolt chain are 2-4 Thunderbay 4 units (I always have at least 2 mounted but sometimes am using all 4). Despite having my energy settings configured as suggested:

- Prevent Mac from automatically sleeping when display is off - CHECKED

- Put hard disks to sleep when possible - UNCHECKED

- Wake for Network Access - UNCHECKED

If the drives idle for about 90 seconds, they will spin down. After being in this spun down state for 10 or so minutes, it will spin up again and repeat the process. Note that not every drive in the chain will do this - they're not all sync'd in this behavior. Sometimes the durations of these events is different and inconsistent.

Additionally, one of the arrays (the first in the chain) is very slow on first access. Once it spins up, its very fast and responsive, but for whatever reason it can take 30 seconds to a minute to load the data into the finder window. I can watch the drive activity lights tick on one at a time, sometimes 1 at a time, sometimes 2 at a time, but theres a whole process that it goes through before it settles into a normal behavior.

This is also reflected in the Softraid where if I launch the monitor, that drive does not even show up In the volumes list for a good 30-60 seconds. The subsequent drives all appear consistently, but that first one does not. Drive is behaving normally otherwise - it just stresses me out a bit to see it MIA from the volumes list, having an empty finder for too long and having these drives constantly spinning up and down.

I would love to be able to confidently sleep my workstation with these drives attached and not worry that theyre going to be spinning up and down all night and putting wear on the drives - but at this point I am not even sleeping my workstation, merely leaving it idle is causing this behavior! Any advice appreciated. 

 

 

 

Quote
Topic starter Posted : 18/11/2021 2:56 pm
(@softraid-support)
Member Admin

Do you have the sleep time set to never? It implies monitor only, but is also disks, in my experience.

this would be annoying, I see this occasionally, but generally it is indexing. I have a system here that is more or less doing what you describe, it has gone to sleep, but the drives keep spinning up and down. This is something in MacOS accessing the disks, usually indexing (spotlight), but not always. So do a test where you exclude spotlight. Also you can exclude spotlight, restart then enable it. That forces a clean index and after it rebuilds (may take a couple days), it may settle down this behavior.

Until this gets resolved, unmount your volumes before walking away, that should prevent this.

ReplyQuote
Posted : 18/11/2021 3:24 pm
(@rustrx)
Active Member

@softraid-support

Just wanted to loop back - removing the drives from the spotlight index definitely seems to have helped the drives from constantly going up/down while the workstation is idle.

One thing that's annoying is that even while editing, if I stop using the application for even a few minutes, the drives seem to spin down and then when I go back into start working again, the drive takes that aforementioned long 30-60 second 'spin up' behavior. Is there some setting where I can define the time-out? I've worked with these Thunderbay units for a long time and don't remember them ever behaving like this with Intel Macs or earlier versions of SR. And really its this one drive (the first in the chain) that's doing this more frequently than others. Generally speaking, it just seems like the drives 'sleep' very quickly and then when it's time to access data, they go through this annoyingly long process to wake up.

ReplyQuote
Topic starter Posted : 24/11/2021 3:55 pm
(@softraid-support)
Member Admin

@rustrx

Sleep is controlled by macOS.

You can go to energy saver. Uncheck put drives to sleep. Also, increase sleep time to a long time, or never. You can still put the system to sleep when you leave, but it won't go to sleep automatically.

ReplyQuote
Posted : 25/11/2021 11:35 am
(@rustrx)
Active Member

@softraid-support

Yeah all that is already set correctly, hasn't fixed it. I've found a post on reddit that seem to identify this as another M1/Monterey issue with drives sleeping too soon, and may not be exclusively linked to OWC/SoftRAID products... will have to wait for another OS update to see. Incredibly irritating as it feels like I am ruining my drives with all this stress! 

ReplyQuote
Topic starter Posted : 25/11/2021 11:43 am
(@softraid-support)
Member Admin

@rustrx

It is frustrating. So you know, SoftRAID has no impact on sleep.

In the google study of 100,000 drives, there was zero correlation with light duty/heavy duty use, power cycles/restarts and longevity, so this is not damaging the drives. But very annoying!

ReplyQuote
Posted : 25/11/2021 2:37 pm
Share:
close
open