Notifications
Clear all

Time Machine Can't Use Volume | Privs, Permissions, Ownership Issues

(@julian-boolean)
Active Member Customer

First off, I want to say that I've been using SoftRaid since 2013 or thereabouts, and thanks for such a great product.

Problem:
I'm suddenly getting the following error message from Time Machine: "Files cant be copied onto the backup disk because it is read only .You may need to repair or erase the disk using disk utility.

What I Have Tried:

1. Volume -> Get info -> Change Privileges to Read & Write. 
This isn't working because all users are greyed out. None of my other volumes are "stuck" like this.
Screen grab attached.

2. Volume -> Get info -> ignore ownership on this drive.
This isn't working because that button is gone.
I've tried un-assigning the drive as a time machine volume. Then re-assigning as TM drive.
I've tried un-mounting, remounting the drive, and multiple shut down and boots.
Screen grab attached.

3. See if SoftRaid reports any problems with this drive.
SoftRaid currently reports no errors on this volume.

Side Note: The volume is a 3 Hard Drive RAID5. A few weeks ago, SoftRaid reported that one of the drives might be damaged. SoftRaid began the rebuild for me automatically without any action from me. This is the beauty of RAID5 :) it took a few days to rebuild, but once completed, the drive and Time Machine were functioning normally and at full speed again.

4. Upgraded from SoftRaid 5.8.3 to 5.8.4.
Same issue persists

What I am hesitant about:

I'd prefer to avoid using Mac's disk utilities if at all possible. First Aid might be able to repair this in 2 minutes, but I've also been sent straight into the 7th circle of hell going down this road before. I've currently got a drive that boots. When Mac First Aid fails to fix an issue, I'm sometimes left with a drive that will not mount again, taking me backwards for a few hours or days rather than forwards toward a solution.

I also have Disk Warrior, which might offer a solution? 

But, I just want to make sure there isn't a shorter / simpler pathway forward.

Thanks in Advance!

------------------------------

• High Sierra 10.13.6

• 2012 Mac Pro 5.1 (Cheese Grater)  12 core, 3.46 GHz, 32 GB 

• 12TB Working Jobs -> Internal Bays 2-3-4, RAID5, 3x HDD (3x 6TB HGST UltraStar) 

• 16TB External Time Machine -> OWC Mercury Elite 4 Bay, RAID 5 (3x  8TB HGST He8)

 

02 VolumePrivs GreyedOut IgnoreOwnershipGone
01 Error TM Volume Is Read Only
03 SoftRaid No Errors

 

Quote
Topic starter Posted : 13/09/2020 7:45 pm
(@softraid-support)
Member Admin

My recommendation is Disk Warrior. Do you have access to it?

ReplyQuote
Posted : 13/09/2020 8:16 pm
(@julian-boolean)
Active Member Customer

@softraid-support, Yes I do have Disk Warrior. I noted this on the 2nd to last line of my first post. Thanks.

ReplyQuote
Topic starter Posted : 13/09/2020 9:20 pm
(@softraid-support)
Member Admin

Run 5.2 on this volume. It should be able to repair it

Good luck!

ReplyQuote
Posted : 13/09/2020 10:35 pm
(@julian-boolean)
Active Member Customer

@softraid-support

Thanks for a great product and your ongoing support. 

I've been running DW 5.2 for about 36 hours now. Still chugging along ... but beginning to wonder about a plan B.  Might be quicker just to reformat the RAID and let Time Machine build me a new backup from scratch.

This problem drive, is an external time machine, with three 8TB HDD in RAID5 (3x HGST He8, RAID5 = 16TB avail, with about 12TB data)
 
Q: Is there any special procedure, or risks I should be aware in reformatting a RAID5 drive that's stuck in "read only" mode?
Obviously there will be data loss, but anything I should know?

Thanks!

ReplyQuote
Topic starter Posted : 30/09/2020 2:29 pm
(@softraid-support)
Member Admin

No, if you erase it with SoftRAID, it will essentially be "like new".

ReplyQuote
Posted : 30/09/2020 5:33 pm
(@julian-boolean)
Active Member Customer

Erasing the volume worked.  Thanks for your assistance on this!  :)   

ReplyQuote
Topic starter Posted : 01/10/2020 1:20 pm
Share:
close
open