Freeze/restart only...
 
Notifications
Clear all

Freeze/restart only when backing up SoftRAID volumes to SoftRAID Time Machine volume

Page 2 / 5
(@stevek)
Trusted Member Customer

Thanks for checking. That's the weird thing, I never get that popup on restart letting me know that a panic even happened. I honestly can't remember the last time I saw one of those and now I'm dying to see one so we can figure this out.

At some point I might just switch from TM to CCC for all my backups instead of just a nightly clone of my startup. If anything, just for a couple weeks to see if that does anything. Or maybe wipe my TM yet again and backup one of my other SoftRaid volumes from scratch — that's when I saw restart after restart. 

Thanks again. Sorry I can't give you any useful information yet.

ReplyQuote
Topic starter Posted : 13/01/2022 4:59 pm
(@softraid-support)
Member Admin

@stevek 

Not a problem. You can give the current beta a try, we put in a change recommended by Apple for Time Machine volumes. Maybe it will help:

http://www.softraid.com/sr_beta

ReplyQuote
Posted : 13/01/2022 9:00 pm
SteveK liked
(@stevek)
Trusted Member Customer

@softraid-support I turned off Time Machine for a few days. No crashes/restarts. I installed the latest SR beta like you suggested a day or two ago and ran it without any problems, then today I turned Time Machine back on. It had a lot to back up because I had recently downloaded some very large files. Not sure if it crashed while TM was running because I was in another room, but it was downloading some more large files to my Media SR volume.

This time when it restarted on its own I actually saw the tail end of the panic message and then, upon restart, the popup with the report. I saved it to a file and attached it. Maybe you can make heads or tails out

of it?

 

ReplyQuote
Topic starter Posted : 20/01/2022 9:25 pm
(@softraid-support)
Member Admin

@stevek 

Did you use the beta that came out today? b8?

 

It should help with Time Machine

ReplyQuote
Posted : 20/01/2022 9:41 pm
(@stevek)
Trusted Member Customer

@softraid-support No, I used the beta from Jan 13 when you mentioned it in your reply above. I’ll install the latest one and try again. Thanks. 

ReplyQuote
Topic starter Posted : 20/01/2022 10:02 pm
(@stevek)
Trusted Member Customer

@softraid-support

Progress! Although Time Machine is awful on large HDDs because of APFS, it was not causing my restarts.

I finally made the time to do more testing and I've narrowed down my constant restart issues.

I usually run qBittorrent at night which was downloading to my Media volume which is on my first SoftRAID ThnderBay, and I would watch a movie using Plex from that same volume over ethernet to my Apple TV. The restarts only seemed to happen when TM would kick in for an incremental update while doing those things.

So, I stopped qBittorent for a few days and only watched Plex while TM backed up and I still had a couple restarts. Next I stopped both qBittorrent and Plex and still had a restart. That narrowed it down to Time Machine or some unknown cause.

I decided to — for the 4th time in 6 months — wipe my SoftRAID TM volume. However this time I took your advice and formatted it as HFS+ and just let it sit there. I stopped using TM for a few days. I had no restarts at all. The problem was gone.

I started testing ChronoSync and Arq to take over Time Machine because you're right, APFS is terrible on HDDs.

The first night I used Arq to perform a full backup of my 1.5 TB Work volume and it restarted. I decided to turn off Spotlight for my Backup volume, erased my failed backup and try a full one again. No restart. More progress.

But last night I used ChronoSync to back up my Media volume which is ~7 TB and and an hour in, it restarted.

I've tried switching Thunderbolt cables and ports on my iMac before but that didn't do anything. The only thing I haven't tried is swapping the HDDs from one ThunderBay to another which might rule out a ThunderBay housing. Then I could try another full backup of each volume using ChronoSync again.

What do you think? 

Would it help to send you a SR and/or a EtreCheck report? Or a Console log?

ReplyQuote
Topic starter Posted : 12/03/2022 1:31 pm
(@softraid-support)
Member Admin

@stevek 

This is not an enclosure issue.

You can send me:

SoftRAID support file

Latest panic log (Report to Apple, save text to text edit, "make plain text" and save)

And you can send the Etrecheck report. I will delete that from your post.

Not sure what I will see that is helpful, but another set of eyes cannot hurt.

ReplyQuote
Posted : 13/03/2022 12:23 am
SteveK liked
(@stevek)
Trusted Member Customer

@softraid-support

Thank you.

When this happens I never get a panic pop up and there's never a .panic log in /Library/Logs/DiagnosticReports.

It restarted maybe 3 times today while I was testing backing up my Media volume, then it also restarted once while manually coping a large 70 GB folder. 

Right after each backup restart I checked the copied file lists and tried to figure out where it was failing, then I excluded those folders but it didn't help.

It won't let me attach the EtreCheck file or a zip. I'll email it to support.

Thanks again. I'll feel so bad for wasting your time if this winds up having nothing to do with SoftRAID!

 

 

ReplyQuote
Topic starter Posted : 13/03/2022 1:31 am
(@softraid-support)
Member Admin

@stevek 

Its OK if it is not SoftRAID causing this, we are here to help where we can. I will take a look at the etrecheck later on.

ReplyQuote
Posted : 13/03/2022 9:03 am
SteveK liked
(@stevek)
Trusted Member Customer

@softraid-support Any progress on this? 

I have found that if I back up those those same two volumes — Work and Media — with CCC, Arq or ChronoSync, it will restart 5 to 10 times, until it unexpectedly works. (It also restarts when copying the contents of those volumes manually in Finder.) Each backup picks up where it left off, so the trick is getting a full first backup, which takes forever. It seems as though once it gets past something or other, regular incremental backups can proceed without restarts.

ReplyQuote
Topic starter Posted : 21/03/2022 8:48 pm
(@softraid-support)
Member Admin

@stevek 

Did you perchance check with CCC to see what file hung? Was it the same one?
I wonder if you "skip" the offending folder, if the backups complete?

It almost sounds like a bad disk, but unless it is USB, SoftRAID should report it to you.

ReplyQuote
Posted : 21/03/2022 10:21 pm
(@stevek)
Trusted Member Customer

@softraid-support Yeah, I thought I could pinpoint it by process of elimination but excluding the enclosing folder(s) didn't help. I mentioned that in my reply on March 13.

I tried rebuilding the directories of my SR volumes with TechTool Pro and started backing up from scratch with a freshly wiped Backup volume yet again but it didn't help, either. And no USB involved with the volumes I'm backing up, nor the backup volume. All HFS+ HDDs, RAID 5, Thunderbolt 2. One ThunderBay on its own port on my Late 2015 iMac 27". (Although I think they use the same controller?)

I'll probably wipe Backup again and start from scratch for the umpteenth time, but I'll try a volume backup every folder excluded except one. Then I'll add a folder and backup incrementally until it restarts. But that will take days.

ReplyQuote
Topic starter Posted : 21/03/2022 11:22 pm
(@stevek)
Trusted Member Customer

So I'm switching from my late 2015 iMac to a 2020 M1 MacBook Air with an external display, at least for now. (This little thing cooks!) I'm now using the Thunderbays with an Apple Thunderbolt 2 to 3 adapter going into one Thunderbay, daisy-chained to the other, then an OWC Drive Dock with two SSDs at the end. I completed a fresh-from-scratch 1.5TB backup with CCC with zero restarts. 

I am having problems with one or both Thunderbays spinning down every few monutes, then coming back up, which is scary. I changed my System Prefs to never let the display sleep. It seemed to work for a bit then it started again. I tried the other thing you mentioned about stopping Spotlight, restarting, turning it back on, etc., and now the drive is busy re-indexing so it hasn't spun down.

But that is probably for another thread. Please let me know if how to proceed with that? 

I was just preparing to do a fresh back up of my huge Media volume but I thought I'd delete some stuff first. While it was deleting a few hundred GB of video it restarted, and for the first time I actually got the SEND TO APPLE window, so I've attached the report.

I'm praying it finally holds a clue to all this restarting nonsense. I was using Mail at the time too. We'll see.

ReplyQuote
Topic starter Posted : 04/04/2022 7:22 pm
(@softraid-support)
Member Admin

@stevek 

Interesting, I just saw this same panic on another user, and had never seen it before:

Attempting to forcibly halt cpu 1
cpu 1 failed to halt with error -5: halt not supported for this configuration

 

Try using "amphetamine" to keep the drives woke.

Your configuration may be a bit "flaky", that is a backwards way to daisy chain. I would see if you can put the Monitor on the dock, and connect the dock directly.

then put the Thunderbay on the other thunderbolt conection. That may be better.

ReplyQuote
Posted : 04/04/2022 9:25 pm
(@stevek)
Trusted Member Customer

@softraid-support 

Apologies for the confusion. OWC Drive Dock is the actual product name of the external drive enclosure I got years ago on clearance. It's a Thunderbolt 2 and USB 3 enclosure with two toaster-style slots on the top for HDDs or SSDs. Super handy for migrating clients' and friends' old laptop drives to new ones.

My chain is: M1 MacBook Air Thunderbolt 3 port --> Apple Thunderbolt 3 to 2 adapter --> Thunderbay SoftRAID Work/Media --> Thunderbay SofRAID Backup --> OWC Drive Dock holding two SSDs.

Today I got the idea to run the two SSDs as a mirrored SoftRAID for speed but it said I needed to upgrade my XT license? I thought it worked with all OWC enclosures? 

Screen Shot 2022 04 04 at 9.38.31 PM
Screen Shot 2022 04 04 at 9.37.46 PM

 

ReplyQuote
Topic starter Posted : 04/04/2022 9:48 pm
Page 2 / 5
Share:
close
open