Monterey APFS suppo...
 
Notifications
Clear all

[Sticky] Monterey APFS support

(@softraid-support)
Member Admin

Discuss APFS volume issues here

Quote
Topic starter Posted : 09/06/2021 3:55 pm
 eggs
(@eggs)
Active Member
Posted by: @softraid-support

Discuss APFS volume issues here

@softraid-support - Any update on the status of APFS support (i.e. ability to mount the volume) in Monterey? I saw there was a change in the most recent beta notes about fixing an issue with APFS and large volume transfers but nothing about the ability to mount APFS formatted volumes.  

Thanks for any updates!

ReplyQuote
Posted : 29/07/2021 8:15 am
(@softraid-support)
Member Admin

@eggs

If you use the SoftRAID 6 beta, you can create APFS volumes. They will auto mount at startup (Assuming the driver loads)

If you unmount an APFS volume, you cannot mount it with the SoftRAID application yet. This will be supported in 6.1. (However you can mount it with Disk Utiliity)

This is all coming in 6.1, I expect some of the main functionality to start arriving in the next 2 weeks.

ReplyQuote
Topic starter Posted : 29/07/2021 11:01 am
 eggs
(@eggs)
Active Member

@softraid-support

Thanks for the reply. It turns out in one of my beta updates that the reduce security allowing extensions to be enabled switched off. Reenabled the allow extensions and now my APFS volume is loading.

ReplyQuote
Posted : 29/07/2021 1:58 pm
 eggs
(@eggs)
Active Member

@softraid-support

I have a planned upgrade to add a disk to my APFS volume and when I went to add the disk the option is greyed out for the APFS volume. Is that unsupported in the beta at this time for M1 APFS support?

ReplyQuote
Posted : 01/08/2021 6:01 pm
(@softraid-support)
Member Admin

@eggs

We will be adding support for more features in a soon to come beta.

However you cannot add a disk to a RAID volume to expand it, only to a mirror to add a secondary.

ReplyQuote
Topic starter Posted : 02/08/2021 11:16 am
 eggs
(@eggs)
Active Member

@softraid-support

 

Thanks for the reply, I was doing a bunch of looking in the forum and reading the SoftRaid manual and I guess I came to the wrong conclusion. Is the only way to expand a RAID volume to delete it and recreate it with the additional disk? I had seen users replace disks with larger disks but it didn't occur to me that I couldn't add a disk to the volume.

ReplyQuote
Posted : 02/08/2021 1:28 pm
(@softraid-support)
Member Admin

Sorry for the confusion. We are unlikely to add this anytime in the near future. its actually difficult to do when the target hardware can be literally anything, to ensure 100% reliability.

ReplyQuote
Topic starter Posted : 02/08/2021 2:06 pm
(@lerxst101)
Active Member

@softraid-support Looking forward to updates, as I just loaded Monterey and SoftRAID 6.0.5 will no longer load -- says I need earlier version of MacOS to run.

ReplyQuote
Posted : 02/08/2021 9:58 pm
(@softraid-support)
Member Admin

You need 6.1 beta for Monterey

 

http://www.softraid.com/sr_beta

ReplyQuote
Topic starter Posted : 02/08/2021 10:50 pm
(@gdecastelaze)
New Member

Hello, I have an OWC Thunderbay with 4 8tb drives. I'm on Monterrey (12.6) and use Softraid 6.3.

I have 2 volumes, one in raid 5 for my files, and the other used to be a Timemachine Backup in raid 5 too.

The timemachine stopped responding, cannot save anymore. And when I try to eject every volume and then stopping the enclosure, I always get the error message from Softraid "disconnected drive does not respond" or something like this.

So I tried to delete the TM volume and make a new one from Softraid, but I get an error message after a few seconds. Error also when I try to "clean" the volume.

Sorry if I'm not very technical or precise there, I'm just a photographer without background in IT.

Capture d’écran 2022 10 30 à 12.07.20
Capture d’écran 2022 10 30 à 12.10.51

Any way to delete that volume that doesn't respond anymore ? If possible without having to reset the whole enclosure and have to copy +15to of files on external drives.

 

Thanks, Gabriel

ReplyQuote
Posted : 30/10/2022 6:11 am
(@gdecastelaze)
New Member

I would like to add that I was prone to this bug : https://www.softraid.com/faq/disks-ejecting-while-in-use/

However I never succeeded in trying to resolve it so far.

ReplyQuote
Posted : 30/10/2022 6:14 am
(@softraid-support)
Member Admin

@gdecastelaze

 

The message you are getting is the volume is busy? time Machine keeps a volume open. Remove it from Time Machine, restart, then try to delete the volume and create a new one.

ReplyQuote
Topic starter Posted : 30/10/2022 5:17 pm
Share:
close
open