Softraid App and Mo...
 
Notifications
Clear all

Softraid App and Monitor fails with error

(@chris6647)
New Member

macOS Monterey 12.3.1 MacBookPro 14" (2021) M1 Max, Thunderbay 4 mini

No Softraid monitor icon in the system menu bar.
Softraid app constantly fails to open with error, except during first launch when it installs the drivers. I never even get the chance to input my license number nor can i use the app to uninstall as the app is unresponsive until the error pops up. If i launch the app while having Disk Utility open, it shows the related warning instead.

SoftRAID Error

An internal part of the SoftRAID Monitor has stopped functioning properly. Please quit SoftRAID and relaunch it.

Issues still occur when the OWC ThunderBay 4 mini is disconnected from the system (and no other external drives are connected)

Can access the APFS volume in Finder and can see the 4 Samsung ssd drives in DiskUtility, along with the OWC Raid volume.

No OWC/Softraid referencing logs in Console.app

No Softraid processes running in Activity Monitor, except when running the Softraid app with its error, then i see SoftRAID and SoftRAIDTool.

Tried with v 6.2.1 and 6.3 b8 to no avail ( http://www.softraid.com/sr_beta)

Have enabled “Allow user management of kernel extensions from identified developers” in recovery mode.
Have allowed the OWC driver to be installed in Security and have given Full Disk access to the Softraid app.

Output of:
sudo kextstat -b com.softraid.driver.SoftRAID

Executing: /usr/bin/kmutil showloaded --bundle-identifier com.softraid.driver.SoftRAID
No variant specified, falling back to release
Index Refs Address Size Wired Name (Version) UUID <Linked Against>
258 0 0xfffffe0006ea0d80 0x4000 0x4000 com.softraid.driver.SoftRAID (6.3b8) 26899627-B7A9-31B9-8CF0-A53E4967D8E4 <16 5 4 3>

Output of:
sudo kmutil load -p /Library/Extensions/SoftRAID.kext

Error Domain=KMErrorDomain Code=71 "Incompatible architecture: Binary is for x86_64, but needed arch arm64e
Incompatible architecture: Binary is for x86_64, but needed arch arm64e
Incompatible architecture: Binary is for x86_64, but needed arch arm64e" UserInfo={NSLocalizedDescription=Incompatible architecture: Binary is for x86_64, but needed arch arm64e
Incompatible architecture: Binary is for x86_64, but needed arch arm64e
Incompatible architecture: Binary is for x86_64, but needed arch arm64e}

Removed quarantine:

sudo xattr -r -d com.apple.quarantine /Library/Extensions/SoftRAID.kext
sudo xattr -r -d com.apple.quarantine /Library/Extensions/OWC_SCSI_Device.kext
sudo xattr -r -d com.apple.quarantine /Library/Extensions/OWC_SCSI_Device_0E.kext
sudo xattr -r -d com.apple.quarantine /Library/Extensions/OWC_SMART_Library.plugin
sudo xattr -r -d com.apple.quarantine /Library/Extensions/OWC_SATA_Command.kext

(app file wasn't quarantined)

 

Tried reinstalling following your guide:

Delete the SoftRAID driver:

sudo rm -r /Library/Extensions/SoftRAID.kext
sudo touch /Library/Extensions
sudo kextcache -fu /

Now, Restart your computer

Remove the daemon and SoftRAID Monitor:
sudo rm /Library/LaunchDaemons/com.softraid.softraidd.plist
sudo rm /Library/LaunchAgents/com.softraid.SoftRAIDMonitor.plist

Remove the SoftRAID application support directory:
sudo rm -r /Library/Application\ Support/SoftRAID

Remove all the SoftRAID preferences:
defaults delete com.softraid.SoftRAID

 

I'm at a loss as to what to attempt next, and honestly I'm worried about using the volume when I'm unable to run the app and monitor the health.

Quote
Topic starter Posted : 05/05/2022 4:44 am
Share:
close
open