Conflict between So...
 
Notifications
Clear all

Conflict between SoftRAID 5.8.4 and Paragon Software NTFS/extFS for Mac drivers?

(@thirtyreset)
New Member

I've been working with OWC Tech Support for a few months now trying to get an Accelsior 4m2 setup in a MacPro 5,1 running Mojave.  At best the system is very unstable when the card is installed, at worst it refuses to boot, simply rebooting constantly in the middle of the startup.

I've finally gotten to the point where I've torn down the system configuration to base install and removed any other PCI cards besides the GPU.  My hardware is fine, I had been using an earlier Accelsior E2 card in the exact same slot with no problems.  What I seem to have found through step-by-step modifications is some form of kernel extension conflict between SoftRAID and Paragon Software's NTFS for Mac and extFS for Mac file system packages.  I wouldn't think these would be particularly uncommon to run into (at least the NTFS package, it continues to be fairly popular), so it surprises me that I haven't run across any reported issues.

Has anyone run into this problem with their installation?  I can live without the extFS capability (mostly there as a backup in case on of my Linux servers has an issue and I need to access a physical file systems), but I regularly use the NTFS capabilities provided by their read/write driver so this is kind of a show-stopper for me at the moment.  Hoping someone else has seen this and has some thoughts, I'm not real confident in this solution at this point and it seems like this would be an issue even when I move to newer MacPro hardware in the near future since it's not a hardware problem but a kernel extension issue.

I have shared SoftRAID logs with OWC Tech Support, not sure if those have been reviewed by anybody from the SoftRAID side of the house or not but can try and share again here if I can get it up and stable long enough to grab something.  It's crashing fairly early in the boot cycle so I haven't been able to grab any console logs that have been helpful so far, hence having to resort to walking back the configuration and adding back in piece-by-piece to get this far.

Thanks in advance for any advice!  Really would like this to work but not feeling optimistic at this point.

Quote
Topic starter Posted : 16/03/2021 2:36 am
(@softraid-support)
Member Admin

This has not hit me yet, no. I am not really aware of an extensions conflict with paragon, though, seems I would have seen it more frequently, I do see the extensions in some support files, but never associated it with any kernel panics. Can you post your case number? I can try to review it.

ReplyQuote
Posted : 16/03/2021 3:50 pm
(@softraid-support)
Member Admin

Want to update this thread. It turns out there is indeed a reproduceable conflict with the paragon NTFS driver.

The use case I encountered was NTFS formatted SoftRAID volumes, which mount fine (read only) on a Mac, but when the paragon drivers are installed, no longer mount.

Do you have a contact from talking to Paragon, or perhaps a thread on the paragon support forums that was active?

 

ReplyQuote
Posted : 12/05/2021 12:27 pm
Share:
close
open