Notifications
Clear all

NSRangeException on most commands

 sco
(@sco)
Active Member Customer

Hi,

I'm trying to use softraidtool and can't seem to use it for any commands that relate to a disk or volume. "help", "showlog 10" work fine.

Here's an example:
$ sudo softraidtool disk all info
2018-09-05 12:44:01.572 softraidtool[1418:18546] Terminating app due to uncaught exception 'NSRangeException', reason: '-[NSTaggedPointerString getCharacters:range:]: Range {0, 22} out of bounds; string length 7'
First throw call stack:
(
0 CoreFoundation 0x00007fff2897f32b __exceptionPreprocess + 171
1 libobjc.A.dylib 0x00007fff4faedc76 objc_exception_throw + 48
2 CoreFoundation 0x00007fff28a10dcd +[NSException raise:format:] + 205
3 CoreFoundation 0x00007fff28889904 -[NSTaggedPointerString getCharacters:range:] + 740
4 CoreFoundation 0x00007fff28893ffd CFStringCompareWithOptionsAndLocale + 4717
5 softraidtool 0x000000010004114a GetEnclosureType + 312
6 softraidtool 0x000000010001e195 start + 118693
7 softraidtool 0x000000010001dc33 start + 117315
8 softraidtool 0x000000010002aa2a start + 170042
9 softraidtool 0x00000001000033f0 start + 8704
10 softraidtool 0x0000000100002e49 start + 7257
11 softraidtool 0x00000001000012cf start + 223
12 softraidtool 0x0000000100001224 start + 52
)
libc++abi.dylib: terminating with uncaught exception of type NSException
Abort trap: 6

I can't even generate a support report:
$ sudo softraidtool generatereport ~/Desktop/test
2018-09-05 12:54:35.272 softraidtool[1528:23553] Terminating app due to uncaught exception 'NSRangeException', reason: '-[NSTaggedPointerString getCharacters:range:]: Range {0, 22} out of bounds; string length 7'
First throw call stack:
(
0 CoreFoundation 0x00007fff2897f32b __exceptionPreprocess + 171
1 libobjc.A.dylib 0x00007fff4faedc76 objc_exception_throw + 48
2 CoreFoundation 0x00007fff28a10dcd +[NSException raise:format:] + 205
3 CoreFoundation 0x00007fff28889904 -[NSTaggedPointerString getCharacters:range:] + 740
4 CoreFoundation 0x00007fff28893ffd CFStringCompareWithOptionsAndLocale + 4717
5 softraidtool 0x000000010004114a GetEnclosureType + 312
6 softraidtool 0x000000010001e195 start + 118693
7 softraidtool 0x000000010001dc33 start + 117315
8 softraidtool 0x000000010002aa2a start + 170042
9 softraidtool 0x00000001000033f0 start + 8704
10 softraidtool 0x0000000100002e49 start + 7257
11 softraidtool 0x00000001000012cf start + 223
12 softraidtool 0x0000000100001224 start + 52
13 ??? 0x0000000000000003 0x0 + 3
)
libc++abi.dylib: terminating with uncaught exception of type NSException
Abort trap: 6

I've tried uninstalling, rebooting, reinstalling SoftRaid 5.6.7 to no avail. I'm currently using a demo version. Previously was using the XT version but I'm looking into using SoftRaid with disks other than those in a ThunderBay (and will upgrade if all good). I'm looking into some automatic scheduled backup via attaching and detaching mirrors, hence the need for the command line interface to work.

I'm on High Sierra 10.13.5.

Any ideas on how to fix this?

Thanks

sco

Quote
Topic starter Posted : 04/09/2018 9:57 pm
(@softraid-support)
Member Admin

No, I have not seen this before. Are there any SoftRAIDtool crash logs in the console.app?
Send us one (support at softraid) and also a tech support file from the GUI if you can create one.

Is the SoftRAID Monitor working consistantly? (The light always there?) Can you launch SoftRAID from it? Are there also any Monitor crash logs?

Do all commands in the GUI seem to work that do not work in the command line?

(They should have the same behavior)

ReplyQuote
Posted : 05/09/2018 11:02 am
 sco
(@sco)
Active Member Customer

No, I have not seen this before. Are there any SoftRAIDtool crash logs in the console.app?
Send us one (support at softraid) and also a tech support file from the GUI if you can create one.

Is the SoftRAID Monitor working consistantly? (The light always there?) Can you launch SoftRAID from it? Are there also any Monitor crash logs?

Do all commands in the GUI seem to work that do not work in the command line?

(They should have the same behavior)

Thanks. I have emailed support with details.

For the benefit of others who may read this...

The GUI works fine and my SoftRaid created volumes are working fine.

Will follow up here with a resolution (if I don't forget to ;-) )

Cheers

sco

ReplyQuote
Topic starter Posted : 05/09/2018 6:24 pm
Share:
close
open