Softraid + Windows ...
Clear all

Softraid + Windows 7 bootcamp = CACHE_MANAGER Blue Screen Error (0x00000034)

New Member Customer

In short:
Softraid + Mac Pro 3,1 w/ os 10.13.6 + bootcamp v6 + Windows 7 = CACHE_MANAGER Blue Screen Errors (0x00000034)

Last july I swapped out a Yosemite booting caldigit raid card for a high sierra booting softraid. Upgraded due to the orphaning of the cal digit raid card and drives by el capitan. Great success.

Since the caldigit raid card had its own ipass connectors for the HD's, I was able to use the motherboard iPass connector for other drives in the optical bay, like a windows bootcamp. I have had the windows bootcamp since 2009 as first a windows XP and now a windows 7.

The upgrade to softraid necessitated the original use of the ipass cable for the four internal drives as the bootable raid 0. So I used the ODD_PASS sata connectors on the mac pro 3,1's motherboard for the bootcamp drive. Bootable mac OS but no booting of the windows bootcamp. Its a mac thing.

This opened up the opportunity to reconfigure my set up a bit. On the mac pro you have four bays via the ipass, one of those were my only option for a bootable bootcamp partition. So I bought an OWC SSD for bay one, used bay 2, 3 and 4 for traditional HHDs raid via softraid. Still a respectable speed. As such I did three things:

Separated my bootable system (On the OWC ssd) from my ~5 TB data of photos and video. Emancipating my ever growing content from a bootable system drive was a goal of mine, as its size is getting unmanageable. Have a sub 2TB bootable system drive opens up the opportunity of using the above mentioned SSD AND crating a bootcamp partition.

So, again, drive bays 2, 3, 4 are a softraid using softraid lite 5.7.2. Drive bay one is using a 2TB own, partition as a 1.5 TB Mac os 10.1.6, and a 0.5 TB MSdos fat 32. I used winclone to transfer my previous and working windows 7 to the 0.5 TB MSDOS fat32 partition.

Everything went fine.

Upon booting the windows partition (I have boot camp 6 installed), I get the login, able to log in, system loads up. everything seems fine and about a minute in, I get the Blue Screen of death with he following message:

CACHE_MANAGER Blue Screen Errors (0x00000034)

here's been my debugging:

1) Redid the winclone of the original windows 7 bootcamp. No dice.

2) Removed all drives, (softraid and bootable system on SSD) and put in the original drive with the original windows 7 bootcamp, it boots fine, so the source of the windows clone is fine.

3) then I removed the original windows drive and replaced the OWC 2TB ssd with the two partitions: Mac os 10.13.6 and the winclone of the above windows bootcamp drive. Again no softraid drives in bay 2, 3 or 4. Everything worked fine.

4) Used this opportunity to update all the drives and system patches for my windows partition in case that was the issue. put the softraid drives back in bay 2,3 and 4 and I got the blue screen of death again, after login into windows and about a minute in.

Seems like by bootcamp windows partition in bay 1 has a problem with the softraid in bay 2, 3 and 4..

From my windows boot,. I can see the traditional mac OS drives attached. (I have two backup drives via carbon copy in the optical bay attached via the above mentioned ODD_SATA connectors on the motherboard) So my suspicion is that a minute after bootcamp boot up, the windows OS looks at the attached mac drives, see's the Softraid and freaks out.

SO I'm putting this out there: do folks have a softraid coexisting with a bootcamp partition? No necessarily on the softraid, this is on a mac OS drive formatted as a MSDOS fat32. Very surprised that I don't see this here on the forum.

Now if the solution is making the softraid invisible from the windows OS, I'm OK with that, I do not need any cross pollinating, and the OWC drive has a bootable mac 10.13.6 on it so If I needed to transfer I can use that drive. windows 7 sees it and it cool with it,.

IF I have to update to windows 10 to fix this (If it is a KNOWN solution, not a guesstimate) I'm fine with that two.

I just can be physically pulling out softraid formatted drive bays 2, 3 and 4 everything I want to use windows.

Thanks for reading this.

Topic starter Posted : 02/01/2019 8:41 pm
Member Admin

Try using MacDrive Pro.

Apparently this is a Windows bug, from my understanding, that is unlikely to be fixed. It is triggered by Windows encountering a partition map format it does not understand.

I am pretty sure Window 10 does not address this issue.

MacDrive has a driver that allows SoftRAID 0 and 1 volumes to mount in Windows. (A RAID 5 mount capability is being worked on, but there is no specific timeline announced yet.)

This should prevent the kernel panics. There is a 30 day trial version of MacDrive available so you can test your configuration.

Posted : 03/01/2019 2:18 pm
New Member Customer

OK, I'll give it a try and report back. I have a raid 0.

Curious if you know if there is a way for softraid to make itself invisible to windows if either and unmount during boot up. thx!

Topic starter Posted : 03/01/2019 6:12 pm
Member Admin

No, I do not.

Posted : 03/01/2019 6:40 pm