Update to 5.8.2 and...
 
Notifications
Clear all

Update to 5.8.2 and volumes do not mount in High Sierra

Page 1 / 2
(@cwallace)
New Member Customer

I have the same problem that they reported in this thread:

https://srforums.wpengine.com/forum/showthread.php?tid=1256&pid=4752#pid4752

Except in High Sierra 10.13.6 on a MacMini Late 2012 with SoftRAID 5.8.2

If I open the app, it says in the bottom right "SoftRAID v 5.8.2 • Driver v 5.8.2"

Upon a fresh restart the "System Preferences -> Security & Privacy -> General" panel has a message that says 'System software from developer "Other World Computing" was blocked from loading' with the Allow button. I can press the Allow button a thousand times and nothing changes. The padlock is unlocked before pressing Allow.

"App Store and identified developers" is selected in the "Allow apps downloaded from:" section.

When I issued the terminal command instructed in the other thread, here is the response:

Kext user-space log filter changed from 0xff2 to 0xfff.
Kext kernel-space log filter changed from 0xff2 to 0xfff.
Requesting load of /Library/Extensions/SoftRAID.kext.
/Library/Extensions/SoftRAID.kext failed to load - (libkern/kext) system policy prevents loading; check the system/kernel logs for errors or try kextutil(8).

The other thread talks about going back to 5.8.1. How do I do that? When I launch the 5.8.1 app it just warns me that the installed version is newer.

Thanks for any help.

Quote
Topic starter Posted : 09/02/2020 3:28 pm
(@softraid-support)
Member Admin

I will research this, but you reinstall the 5.8.1 driver by running the app.
Select your startup volume.
"Reinstall SoftRAID driver" (Might say update in the menu)
restart.

Also, check you are following each step here:
https://www.softraid.com/pages/support/5.8_Volumes_Not_Mounting.pdf

ReplyQuote
Posted : 10/02/2020 3:05 pm
(@rene-van-der-hulst)
New Member Customer

This problem just happend to me as well :

OSX 10.11.3 : Updated app + driver to 5.8.2 from 5.8.1. and volume not mounting anymore. Tried the mentioned solution on the forum in the Security and Privacy settings to no avail. Still not working after several restarts and cleaning with Onyx

I went back to 5.8.1 and everything is fine again. How to get back to 5.8.1 :

1) Select your Startup Volume 'OS X 10.11,X' in Softraid 5.8.2 version
2) Under 'Volume' in the menu choose 'uninstall driver'
3) Restart
4) Run 5.8.1 version from the Program Menu
5) Message will appear app will not work without driver, choose 'Install Driver'
which will install the 5.8.1 version
6) restart

After this everything is working fine again om my Imac.
Kind regards,

rene van der Hulst

ReplyQuote
Posted : 11/02/2020 11:16 am
(@softraid-support)
Member Admin

The problem is you need to allow "Identified Developers" in particular Other World Computing, as per this document:

The problem is the SoftRAID driver is prevented from loading by OS X security. You need to approve OWC as an "Identified Developer".

We created a PDF with instructions to help you resolve this problem:
https://www.softraid.com/pages/support/5.8_Volumes_Not_Mounting.pdf

ReplyQuote
Posted : 11/02/2020 11:29 am
(@softraid-support)
Member Admin

We are going to do a 5.8.3 that will either/both fix this, or have better notifications. the security changes are happening so fast, and are often unpredictable in OS X.

I am guessing we may have to move closer to removing SoftRAID's bundled driver from the shipping OS X releases. It would resolve most (maybe all) of these issues, at the cost of automatic compatibility when a user connects a SoftRAID set of disks to a new Mac.

Would be a shame if we had to do that.

ReplyQuote
Posted : 13/02/2020 12:48 am
(@crhendo)
Eminent Member Customer

We are going to do a 5.8.3 that will either/both fix this, or have better notifications. the security changes are happening so fast, and are often unpredictable in OS X.

I am guessing we may have to move closer to removing SoftRAID's bundled driver from the shipping OS X releases. It would resolve most (maybe all) of these issues, at the cost of automatic compatibility when a user connects a SoftRAID set of disks to a new Mac.

Would be a shame if we had to do that.

I have three Mac's all running SoftRAID with ThunderBays attached. All of them are headless and two of them require the ThunderBays to be present at boot (with hours lost to DB recoveries if the Thunderbays aren't present). The third one is my personal Mac Mini with a 20TB external "iTunes Library" that with the introduction of Catalina now requires to be present at boot!

Please don't remove the bundled driver from the shipping OS X releases.

ReplyQuote
Posted : 13/02/2020 6:09 pm
(@softraid-support)
Member Admin

Don't worry, that is one person talking not the company.

But even if we did, the result would only be a new clean system install would not mount SoftRAID drivers, but after running SoftRAID, it would. It would fix the problem of Catalina "downgrading" SoftRAID with each .1 increment.

But we really like the idea of connecting a Thunderbay or enclosure with SoftRAID disks to any random Mac OS computer and it auto mounting, even if all features were not fully available.

We are waiting to see what 10.16 does to the driver model. Apple has announced it will change but as of this time, the changes are unknown. (and no one will be able to discuss them until after the release, of course)

ReplyQuote
Posted : 13/02/2020 7:03 pm
(@marc-db)
New Member Customer

"I can press the Allow button a thousand times and nothing changes. The padlock is unlocked before pressing Allow."

I had the same problem, but found that 5.8.2 had not filled in my serial number. After filling the serial number in manually, I could finally press 'Allow' in System preferences. Restarted and everything works fine again.

Marc

ReplyQuote
Posted : 21/02/2020 3:28 am
(@softraid-support)
Member Admin

Interesting, Entering your license should not have an impact, but I will discuss this in an engineering meeting next week.

ReplyQuote
Posted : 21/02/2020 11:09 am
(@rwaterbury)
New Member Customer

Same issues on a Late 2012 Mac Mini with High Sierra 10.13.6. I re-entered my serial number, and still cannot allow OWC Developer. Downgrading to 5.8.1 allowed me to remount my RAID.

ReplyQuote
Posted : 28/02/2020 11:50 am
(@softraid-support)
Member Admin

One more thing to try (since you know 5.8.1 works)

Check the System Preferences Security pane is open and unlocked.
Run 5.8.2
Update the driver.
if you get the option, allow.
Else, restart, and see if the volumes mount.
Run SoftRAID 5.8.2
See if you get the "Allow this Developer" option. ALlow if so.
Reinstall SoftRAID driver, onto your statup volume once more.

See if this solves this. Once done, this issue will not come back, as this is the new "Developer Identity" for SoftRAID.

ReplyQuote
Posted : 28/02/2020 12:40 pm
 TomW
(@tomw)
New Member Customer

Arrgh. Same issue here, but not fixed yet.
Mac Mini Mid-2011 running OS 10.13.6
I updated from 5.7.5 where everything was working fine. With 5.8.2 the volumes will not mount and I have had the problem with an unlocked security panel not allowing the driver to load.
Running kextstat -b com.softraid.driver.SoftRAID shows no driver. Trying the fix, it will not allow me to reinstall the driver on the boot volume. The log shows: Mar 3 1835 - SoftRAID Application: The driver install command for volume "MiniServer Boot" (disk3s1) failed with an error (error number = 10).

Try to fix the issue with the security panel in preferences where unlocking and then clicking to allow software from OWC to load does nothing - click to allow and it does nothing. Opening SoftRAID, selecting the startup volume, and try to reinstall the softRAID driver fails every time.

What do I try next?

ReplyQuote
Posted : 03/03/2020 9:26 pm
(@softraid-support)
Member Admin

Try this command in terminal:
kextstat -invalidate
Then restart and run SoftRAID
Can you install the driver now?

ReplyQuote
Posted : 04/03/2020 12:55 am
 TomW
(@tomw)
New Member Customer

After wasting 3+ hours yesterday doing the update and then trying to figure out what went wrong and how to undo it, I'm not interested in spending even more time trying various things that may or may not work. 5.7.5 works and 5.8.2 does not. I'll wait and try 5.8.3 when it comes out to see if you have fixed the issues.

ReplyQuote
Posted : 04/03/2020 12:23 pm
(@softraid-support)
Member Admin

This problem will not go away until 10.16, as this issue was created by Apple's security defenses. Once you resolve it, however, it will permanently be resolved, as it is a Developer Identifier related issue.

I can handle you directly if you email support @ softraid.

Really sorry about this, we are caught between a rock and a hard place so to speak. Apple is taking security extremely seriously, which is good, but they do not aways share security changes with developers until final release.

ReplyQuote
Posted : 04/03/2020 12:47 pm
Page 1 / 2
Share:
close
open