Kernel Panics with ...
 
Notifications
Clear all

Kernel Panics with SoftRAID 6.0.5 on M1 macOS 11.4

Page 1 / 4
(@njm973)
Active Member

Hi - I've been attempting to set up an array using the ThunderBay Express 4M2 and am constantly getting Kernel Panics when the array is placed under load. Below is a summary of how Ive set up and what I've tried so far to resolve.

 

Setup:

Brand new Express 4M2 with 4x 4TB Mushkin SSDs

M1 Mac mini with a fresh install of MacOS 11.4 (installed clean from the recovery OS, not patched from 11.3.3)

SoftRaid is the only Ktext that is loaded

The disks all passed certification, the array was created as RAID4, and mounds successfully

I am able to transfer/read files on the array

 

Problem:

System is experience intermittent Kernel Panics and rebooting

Error reports are being generated that indicate the softRAID driver (6.0.5) in the trace

 

Steps to reproduce:

1) Place array under load

2) Wait

For this purpose I have been using Adobe Lightroom to download a copy of my photo library to the array (~1.5TB)

 

Things Ive tried:

- Restarting

- Fresh install of macOS

- Verifying permissions and that the driver loads

- Loading and unloading the ktexts

- crossing my fingers

 

At this point I can't get the array stable enough to make use of it and I'm out of things to look at or try. Happy to prove more details reports or stack traces if you can tell me what's useful. Any help is appreciated! 

Quote
Topic starter Posted : 10/06/2021 12:53 pm
Topic Tags
(@softraid-support)
Member Admin

Attach a SoftRAID tech support file. I need the panic log. Best way to get it is after a crash, "report to Apple" on restart, get more info and paste the output into a text edit file, convert it to plain text and save, then rename to .txt and attach it.

ReplyQuote
Posted : 10/06/2021 1:42 pm
(@njm973)
Active Member

@softraid-support

Sure.

Here is the tech report. I will generate the crash report after the next one. In the mean time I was going to share the full Panic report from earlier today, but the forum is not letting me attach a .zip, .txt, or .report file (says unsupported file type). What's the trick?

ReplyQuote
Topic starter Posted : 10/06/2021 2:14 pm
(@softraid-support)
Member Admin

@njm973

.txt Just unzip it and save it with a .txt suffix (change the extension, it is probably a .panic?)

hte reason the "more info" logs are better is the macOS versions now are often filled up with garbage text, making it harder to deal with.

ReplyQuote
Posted : 10/06/2021 2:25 pm
(@njm973)
Active Member

@softraid-support

That's fine, just a matter of waiting. However, I tried all those extensions (edited them directly) and the forum refused each one. (This is a plain text file I made by cutting/pasting from the .panic log)

ReplyQuote
Topic starter Posted : 10/06/2021 2:29 pm
(@softraid-support)
Member Admin

@njm973

We should accept .txt. Use "get info" to rename it, so you are sure to change the hidden extension name.

ReplyQuote
Posted : 10/06/2021 3:41 pm
(@njm973)
Active Member

@softraid-support

Yeah, that's exactly what I did. I also just tried to upload a blank test file that I created from scratch. No dice. It's also refusing to let me upload the screenshot (.png) that I just took to try and show you.

ReplyQuote
Topic starter Posted : 10/06/2021 3:49 pm
(@softraid-support)
Member Admin

@njm973

Because of hacking, we limit to jpg and .txt. I may be able to add some other file format.

I just tested a .txt file, it works. Remember text edit only saves as .rtf. It no longer has a text file, so you make plain text, then change the name. I will look into allowing .rtf file types.

ReplyQuote
Posted : 10/06/2021 5:16 pm
(@njm973)
Active Member
screenshot

@softraid-support

Ok. So I changed absolutely nothing, it's exactly the same file as before, but this time it worked. Here is the full Panic Report. I'll post the shorter file after the next crash, it seems to happen somewhat randomly, but suspect it will be soon. (I also attached the jpg of this failing earlier so you can see that I wasn't crazy.)

 

ReplyQuote
Topic starter Posted : 10/06/2021 7:46 pm
(@softraid-support)
Member Admin

@njm973

I also need a core dump after a crash, since this is ARM. here are the instructions. When you post the link to the files, I will delete the link.

What this means is a way to get a capture of all the backtraces in the kernel panic that you are seeing.

Here is how to create a Core Dump. What we need is the following. Set up the computer as follows:

Shut Down your M1 computer.

1. disable System Integrity Protection:

Startup into internet recovery mode. the sequence on the M1 is this:
Hit the power button once, then hold it down until you see the options window.
Click options, then continue.
Next screen click your startup volume. (f there is more than one)
Next screen again and enter your password
The macOS recovery screen should appear, go to the startup menu and run the "terminal.app"
Enter:
csrutil disable
It may give you a list of systems if you have more than 1.
If so, select the active startup volume, then enter y for yes in the next prompt
enter password again

2. Put the computer into debugging mode

Set NVRAM to capture the dump:
run the terminal.app in normal mode.
Paste this command in:
sudo nvram boot-args="debug=0xd44"
restart.

3. Create the core dump

Next time you panic, or hang, hold on to the power button for 1 second (only).
If the machine restarted from the crash, hold the power button for exactly 1 second immediately after restart.

4. Wait ten minutes, then use "go to folder" to go here:
/private/var/tmp/kernel_panics

There should be a file.

Now run the terminal.app and save a system Diagnostic file:

sudo sysdiagnose -f ~/Desktop

now, save a SoftRAID Technical support file.

Once you do this, I will want all three files. (it will be quite large)

We can transfer using "wetransfer" but please use the exact instructions are below. If you post the we transfer link to your post, I will delete it, so the files do not become public.

Instructions to send the Core dump, System Diagnose and tech support ffile:

go to the url:
wetransfer.com
Click the button that says "I Agree".
Click the "Add your files" button and select the Sysdiagnose file.
Click the ... Button.
Select the "Get transfer link" button.
Click the large "Get a Link" button.
After a short period of time, the wetransfer site will give you a link.
Send that link to us.

After you generate a core dump from a crash, you can undo the settings by:

go back into internet recovery mode:
csrutil enable

And after a normal boot, this terminal command will set NVRAM back to default:

sudo nvram boot-args=

 

ReplyQuote
Posted : 11/06/2021 10:01 am
(@ptrickwondo)
Active Member

I appear to be having the same issue. Under load, the screen flashes pink, and my M1 iMac restarts. However, I don't get a "report to apple" option on restart. Any suggestions on how to share a log to see if I'm having the same issue?

I've managed to get repeated crashes when iDrive is trying to backup files from my ThunderBay 4 or when I open a library in Final Cut Pro that's saved on my ThunderBay and try to work with the files. If the FCPX library is on the local drive on the iMac or if iDrive is backing up local files, no crashes.

Thanks!

ReplyQuote
Posted : 27/06/2021 5:22 pm
(@softraid-support)
Member Admin

@ptrickwondo

Run the Consolte.app and look for diagnostic reports that correlate to the crashes. There should be panic logs, but not always. M1 is not complete as far as crash debugging goes.

If you temporarily uninstall iDrive, do you still get the crashes with FCP?

ReplyQuote
Posted : 27/06/2021 11:02 pm
(@charlie)
Active Member

Hi, I have met the same issue with kerne panic as some information below.

 

panic(cpu 1 caller 0xfffffe001f28cbb4): SoftRAID driver - pool null ptr

Debugger message: panic

Memory ID: 0x6

OS release type: User

OS version: 20F71

Kernel version: Darwin Kernel Version 20.5.0: Sat May  8 0531 PDT 2021; root:xnu-7195.121.3~9/RELEASE_ARM64_T8101

Fileset Kernelcache UUID: FB10CC0AB8BAC020BC47A50D64476F11

Kernel UUID: 07259C53-9EF7-32FF-821D-8F28A5985DFA

iBoot version: iBoot-6723.120.36

secure boot?: YES

Paniclog version: 13

ReplyQuote
Posted : 30/06/2021 8:45 pm
(@softraid-support)
Member Admin

@charlie

This is not a panic I am familiar with, and it is referencing a null pointer, which would likely be a SoftRAID driver issue/bug.

Can you save the full panic report into a text edit file? And I would like a SoftRAID Tech Support file. thanks

ReplyQuote
Posted : 01/07/2021 10:18 am
(@softraid-support)
Member Admin

@charlie

This is not a panic I am familiar with, and it is referencing a null pointer, which would likely be a SoftRAID driver issue/bug.

Can you save the full panic report into a text edit file? And I would like a SoftRAID Tech Support file. thanks

ReplyQuote
Posted : 01/07/2021 10:21 am
Page 1 / 4
Share:
close
open