Big Sur on M1 machi...
 
Notifications
Clear all

[Sticky] Big Sur on M1 machines and SoftRAID issues

Page 1 / 51
(@softraid-support)
Member Admin

April 26, 2021

Important: this post has been updated with the release of macOS Big Sur, 11.3.

macOS Big Sur, version 11.3, fixes the issue preventing the SoftRAID driver from loading.

SoftRAID 6 can manage and mount all SoftRAID volume types on Apple M1 computers

 

Note: you must allow third party developers, in every macOS System for M1 computers, per these instructions from Apple:

https://support.apple.com/en-lk/guide/mac-help/mchl768f7291/mac

Select reduced security and enable this:
Select the “Allow user management of kernel extensions from identified developers” checkbox to allow installation of software that uses legacy kernel extensions.

When you install the SoftRAID driver, you must "Allow" OWC as an identified developer. Its best to do it before you restart, after installing the driver,go to Security Pane and unlock, then click Allow. now you can restart and the SoftRAID driver will install and load on restart.

Users who signed up to "Critical Issues" will receive a notification about this via email. If you want to get important notices that may affect you and your use of SoftRAID, (this is not sales/marketing emails), sign up to be on the notifications list.

https://www.softraid.com/news/softraid-news/

 

We have additional performance optimization enhancement for newly created volumes, but volumes created on intel computers perform the same on M1 as on intel CPU's.

 

If you are reading this thread after April 26, 2021, then this thread is obsolete all the way to page 45.

The original problem:

macOS Big Sur 11.2 for the M1 computer does not work with SoftRAID. There is a bug that blocks the SoftRAID driver from loading.

Solution:

The fix for this problem is included in macOS 11.3.

 

This topic was modified 4 months ago by SoftRAID Support
This topic was modified 3 months ago 2 times by SoftRAID Support
This topic was modified 3 months ago by Jeff Jorgensen
This topic was modified 2 months ago by SoftRAID Support
Quote
Topic starter Posted : 18/12/2020 5:29 pm
Topic Tags
M1
(@woodstocknick)
Active Member

Thank you for your hard work in making this available. No issues accessing my RAID 5 APFS volume so far running on an M1 MacBook Pro.

I noticed a couple things with the app. There's no status displayed on the menu bar even though it's enabled. 

Also my volume shows unmounted in the application though it seems to be working fine. Just checking if that's expected behavior at this time.

ReplyQuote
Posted : 18/12/2020 9:28 pm
(@darren-curtis)
Active Member

Christmas comes early! Thank you. 

ReplyQuote
Posted : 18/12/2020 9:48 pm
(@softraid-support)
Member Admin

thanks, all.

I will look out for SoftRAID Monitor issues, yes it should be showing in the menu.

 

SoftRAID application does not yet support APFS. they will work, but the application cannot mount/unmount  them and does not really see them correctly. Not an issue, it is just the application, not the driver.

ReplyQuote
Topic starter Posted : 18/12/2020 9:59 pm
(@kaijujoe66)
Eminent Member

Thanks for making this work on M1!  I can confirm that it is running and mounting volumes on my Mac mini M1 connected to two ThunderBay 4s, One Thunderbay IV and an Apple Thunderbolt display. I am reading and writing to previously created volumes just fine.

ReplyQuote
Posted : 19/12/2020 9:59 am
(@kaijujoe66)
Eminent Member
Posted by: @softraid-support

We have performance optimization to work on for new volumes, but older volumes should be OK.

So happy that this is available now.  Thanks for the hard work and can confirm access to SoftRAID volumes on my M1 Mac Mini.  As for new volumes, given the above statement, should I create new volumes on an intel Mac if I can and then migrate them to my M1 Mac?

ReplyQuote
Posted : 19/12/2020 10:01 am
Craignos
(@craignos)
Active Member

Running beta 6.0.1b46 on M1 MacBook Pro, my Thunderbay 4 in RAID5 is showing in the app but won't mount. No menu bar status as well.

So frustrating! Even right-clicking on the volume and selecting "mount" doesn't work. I uninstalled all version of Softraid, restarted, re-installed the beta...

HELP!

 

ReplyQuote
Posted : 19/12/2020 10:22 am
(@softraid-support)
Member Admin

Was this a clean install, or a migration?

If you run SoftRAID and then open System Preferences, /Security, is the option to "Approve Developer" there?

 

If you run kextstat in the terminal.app and search for softraid, is it in there?

 

My guess is you did not approve OWC as a developer.

ReplyQuote
Topic starter Posted : 19/12/2020 10:25 am
(@softraid-support)
Member Admin

@kaijujoe66

 

Give it a try. We wanted to get this out, so all permutations have not been tested.

But for sure all volumes created on intel machines will mount on M1.

ReplyQuote
Topic starter Posted : 19/12/2020 10:31 am
Craignos
(@craignos)
Active Member

@softraid-support yes, correct! Thanks!

ReplyQuote
Posted : 19/12/2020 10:46 am
(@mushbuddygoose)
Active Member Customer

Having some major issues. But I think it may be related to the OWC MEP Quad and USB 3. Running Big Sur 11.1 on a MM M1. Here are he steps and logs. Note. I had previously set up Softraid under 5.8.4 Xt with a RAID 5 and RAID 0+1 volumes across 4 disks in my mercury elite.Moving it to the M1 machine, did the following:

  • I turned off SIP, rebooted
  • downloaded beta 46. I installed the driver. 
  • After installation, I allowed it from the security settings.
  • Then got a message about changing security settings for new security policy settings
  • Rebooted into recovery. Changed the security policy to most permissive. Rebooted again.
  • Application monitor didn't show monitor in the menu bar. But I the volumes were showing up in the application, however they are unmounted. And I couldn't get them to mount.
  • Then I noticed under security settings that it was asking me to allow OWC as a developer. I selected that option, and rebooted.
  • Now problems started, kept getting kernel panics. After I enter my password for my user name, machine keeps rebooting.
  • I turn off the MEPQ and reboot and computer loads. I get the following crash report (attached: NOTE: not allowing me to attach file so attaching via link). Still no application running in menu bar.
  • I give Softraid app full disk access. Reboot. Still no monitor running in menu bar.
  • Now I turn on the MEPQ, the disks and volume show up. I can see the begin to mount and then kernel panic.

So basically I cannot get it the volumes to mount. Any ideas?

 

FWIW, I did try both USB3/TB ports on the Mac mini with no luck. I also tried two different cables. Same result.

Crash.txt link : https://www.dropbox.com/s/qjo0jk7qnofu9rw/crash.txt?dl=0

ReplyQuote
Posted : 19/12/2020 11:51 am
(@mountainman)
Active Member

Unfortunately for me (M1 Mac mini), the Softraid 3rd party extension prevents boot up and eventually leads to a Panic Medic Boot where extensions are disabled to successfully boot.  I've decreased security in recovery mode to lowest level (and allow administrator both options checked).  If I approve OWC extension it just results in another Panic Medic Boot.

ReplyQuote
Posted : 19/12/2020 11:58 am
(@mushbuddygoose)
Active Member Customer

Sorry. Quick follow up so its clear. The MEPQ seems fine when the volumes aren't mounting. The computer sees it. Disk utility sees the disks. Its only after I allowed OWC as an allowed developer and the machine tried to mount the volumes that I started getting kernel panics.

ReplyQuote
Posted : 19/12/2020 12:01 pm
(@mountainman)
Active Member

@craignos Your extension isn't loaded.  For me (Mac mini M1), if I boot in recovery mode -> options -> (menu) security settings and reduce to lowest level then allow OWC extension to load, it prevents the Mac from booting and to successfully boot the Mac has to disable all extensions again.

ReplyQuote
Posted : 19/12/2020 12:08 pm
(@pruthe)
Eminent Member

Hi all,

I just joined this forum. I downloaded Softraid beta today and installed on my M1 Mac mini. Got my OWC and Akitio 4-drive enclosures running now. I ran into same problem as @Craignos until I ran procedure to change boot policy. Required following below procedure.

1. Shutdown your Mac
2. Press and hold the power button to enter Recovery mode.
3. Choose Options, and click Continue. Go to Utilities -> Startup Security Utility.
4. Set the security level to Reduced Security, choose the option to “Allow user management of kernel extensions from identified developers” and click OK to continue.
5. Reboot normally back to macOS.

After this, install Softraid beta and make sure Softraid extension is allowed when asked in Security & Privacy pref. I think restart was requested again. After this, my Softraid drives mounted.

I think this is close to the procedure I followed.  If corrections needed, maybe Softraid support guys can correct and post here.

Good Luck!

pruthe

p.s. Apologies if install procedure is given elsewhere. I'm still not familiar where everything is on this forum. :-)

ReplyQuote
Posted : 19/12/2020 12:48 pm
Craignos liked
Page 1 / 51
Share:
close
open