Notifications
Clear all

Cannot certify a disk

(@bscardin)
New Member

I recently had a drive fail in a RAID 5 set and I'm trying to replace it with another drive that I had been using for Time Machine.  I erased the disk using Disk Utility using Mac OS Extended (Journaled) and then unmounted it using Disk Utility.

In the SoftRAID app the drive shows linked to the Volume that was created in Disk Utility and the Volume shows "unmounted" next to the name.  However, when I select the disk and choose Certify it immediately pops up an error dialog that says:

SoftRAID Error

An error occurred certifying a disk.  An error occurred (error # 0).

Disk with error: disk3, SATA bus 0, ID 4 (Thunderbolt), 3 TB

 

If I try to zero the first and last 100 sectors using "Zero sectors" I get a different error:

SoftRAID Error

An error occurred writing zeros to a disk.  The disk is currently being used by anothe rapplication.  Please quit all other applications and try again.

Disk with error: disk3, SATA bus 0, ID 4 (Thunderbolt), 3 TB

 

I tried unmounting the disk using Terminal with the following commands too:

sudo diskutil unmount force /dev/disk3

sudo diskutil unmountDisk force /dev/disk3

But neither of those changed the behavior.

What else can I do?  I'd really like to get the drive replaced in the RAID -- I don't like living without redundancy here!

 

Thanks!

Quote
Topic starter Posted : 10/12/2020 7:35 pm
(@bscardin)
New Member

I think I solved my own problem.  I had to change the permissions under "Security & Privacy"

 

Security & Privacy -> Privacy, Select Full Disk Access, Check the box next to SoftRAID 5.8.4.app

ReplyQuote
Topic starter Posted : 10/12/2020 8:06 pm
(@softraid-support)
Member Admin

Yes. That is important, good that you fixed it yourself!

ReplyQuote
Posted : 10/12/2020 10:24 pm
Share:
close
open