SoftRaid will not l...
Clear all

SoftRaid will not load

2 Posts
2 Users
Posts: 1
New Member
Topic starter

I cannot get SoftRaid to load. I've tried both 6.3 and 7.0.1 (fully removing the program each time as below) and get the following errors:

With 6.3:

" SoftRaid 6.3 is trying to install a new helper tool" then after I enter my password nothing happens 

and with 7:

"SoftRAID 7.0

SoftRAID 7.0.1 is trying to install a new helper tool

Enter your password to allow this"


"SoftRAID Error

The SoftRAID application cannot initialize itself correctly.

Please try booting from a different volume and try again."


I followed these steps to fully remove the program:

Delete the SoftRAID driver:
sudo rm -r /Library/Extensions/SoftRAID.kext
sudo touch /Library/Extensions
sudo kextcache -fu /

Now, Restart your computer

Remove the daemon and SoftRAID Monitor:
sudo rm /Library/LaunchDaemons/com.softraid.softraidd.plist
sudo rm /Library/LaunchAgents/com.softraid.SoftRAIDMonitor.plist

Remove the SoftRAID application support directory:
sudo rm -r /Library/Application\ Support/SoftRAID

Remove all the SoftRAID preferences:
defaults delete com.softraid.SoftRAID

Remove preference files
sudo rm -r

reset the extensions caches:
sudo kmutil clear-staging
sudo kextcache -i /

Restart the Mac. SoftRAID volumes will no longer mount on the desktop, but that is temporary, until you reinstall the driver.

When you run SoftRAID to install the driver, do not immediately restart. wait until the dialog box pops up to go to System Preferences/Security. "Allow" OWC as an Identified developer, now restart, (you have to maneuver around a couple different restart buttons SoftRAID and macOS)

But still I get the same error message and the program doesn't start

Having removed all traces of the program, I cannot get the volume to mount but I can't install the program either.

How can I fix this?


Posted : 26/02/2023 4:05 pm
Posts: 7124
Member Admin

FYI: with 6.3 and later, we made this easy, with the command line:
sudo softraidtool uninstall

When you launch SoftRAID with nothing installed, it runs, correct? it is only after the restart that you cannot run the application?

Posted : 28/02/2023 1:03 pm