Running SoftRaid on...
 
Notifications
Clear all

Running SoftRaid on Apple Silicon (M1) Macs including 2020 Mac Mini with M1

Page 10 / 13
(@softraid-support)
Member Admin

@effndc

 

The forum is limited to jpg and sr_supt at the moment. I am considering adding a form of text file, we also need to let users know what it is , etc. (something like a .panic, perhaps .txt, i do not want content files uploaded that could be used to compromise the forum, this is WordPress, which is susceptible to various hack attempts, so this particular forum has built in limitations.

Here is what to do:

Send the file to me via "wetransfer.com".
Instructions to send the System Diagnose file:

go to the url:
wetransfer.com
Click the button that says "I Agree".
Click the "Add your files" button and select the Sysdiagnose file.
Click the ... Button.
Select the "Get transfer link" button.
Click the large "Get a Link" button.
After a short period of time, the wetransfer site will give you a link.
Send that link to support at softraid. Copy the URL above, and add your user name, so I know where it came from.

Don't auto send it (the default method) as it will take much longer for me to receive it. Keep in mind that Apple does not have a debugger yet for the M1.

ReplyQuote
Posted : 10/01/2021 12:50 am
(@effndc)
Active Member Customer

@softraid-support I just wanted to provide an update for my issue, so far it seems that my issue was actually due to filesystem permission conflicts.  I forgot how fickle macOS was with HFS+ file permissions, and in my case I was moving an existing SoftRAID volume to a new M1 Mac mini with permissions in place...after fixing ownership/userID mismatch across the entire SoftRAID volume it has been stable...or it was related to having RAID5 and a RAID0 volume on the same 4 SSDs, I consolidated to only the RAID5 volume.  

Either way, so far it has been stable (hopefully I am not jinxing myself) and have a week of uptime.  This is why I didn't bother uploading the sysdiagnose and other crash reports, if anything changes for the worse I will update you.  As of now the RAID5 volume reports 630k I/O requests and counting with no errors. 

ReplyQuote
Posted : 16/01/2021 7:34 pm
Sunstarfire
(@sunstarfire)
Estimable Member

Any news when the Beta will work on Big Sur 11.2? The RC is out, and the release will come soon. Until now, 11.1 runs fine, with USB and Thunderbolt-Panics (Apple's problem). But the beta should kinda work on 11.2.

ReplyQuote
Posted : 25/01/2021 8:02 am
(@softraid-support)
Member Admin

The weird thing is I am getting 11.2 to work without problem. I need to be able to reproduce it.

 

Were you running 11.1 beta, or release? I am able to do both a clean install and an install from 11.1. More info may be helpful here. thanks!

ReplyQuote
Posted : 25/01/2021 10:16 am
(@effndc)
Active Member Customer

I am unable to get SoftRAID b48 to work on 11.2, it won't mount the drives.  No obvious errors in system log and the SoftRAID log says nothing, even after manually selecting to mount nothing happens:

Feb 01 1410 - SoftRAID Monitor: Starting SMART test on all disks which support SMART.
Feb 01 1753 - SoftRAID Application: Launching application: SoftRAID version 6.0.1 b48
Feb 01 1754 - SoftRAID Monitor: SoftRAID Monitor loaded, version 6.0.1 b48.
Feb 01 1703 - SoftRAID Application: Launching application: SoftRAID version 6.0.1 b48

ReplyQuote
Posted : 01/02/2021 7:42 pm
(@softraid-support)
Member Admin

MacOS is blocking the driver from loading, it will be fixed in 11.3. So you need to go back to 11.1.

You should be able to do so using Snapshot recovery. We have instructions posted, if you need them.

ReplyQuote
Posted : 01/02/2021 8:06 pm
(@yangster888)
Active Member

@softraid-support I updated to 11.2 before seeing this post.  I never created a snapshot nor do I use time machine for backup.  How do I go back to 11.1?  Can you provide a link to the instruction? https://eshop.macsales.com/blog/56681-working-with-macos-snapshots/ this is the one I found via goole.  thanks

ReplyQuote
Posted : 01/02/2021 9:36 pm
chesterloke
(@chesterloke)
New Member

@yangster888

 

You can check it here. https://srforums.wpengine.com/how-to-use-snapshots-on-m1-apple-silicon-computers/

At First Page, we believe that the success of our clients defines the yardstick of our own success. We will exert great efforts to turn every SEO campaign into a success story.

ReplyQuote
Posted : 01/02/2021 10:16 pm
(@softraid-support)
Member Admin

Try this:

https://srforums.wpengine.com/how-to-use-snapshots-on-m1-apple-silicon-computers/

Pay close attention to each step, even if obvious. Let me know if it works.

ReplyQuote
Posted : 01/02/2021 10:23 pm
(@darren-curtis)
Active Member

@softraid-support Hey, just updated automatically to 11.2 and thunderbay 4 does not mount because of driver issued. Tried using the snapshot but every one of them dating back 24 hours was also listed as 11.2 even though the update happened at 8 pm Feb. 1. Is there any other work around? Thank you.

ReplyQuote
Posted : 01/02/2021 10:39 pm
(@softraid-support)
Member Admin

No, but what if you take the closest one that is 24 hours?

ReplyQuote
Posted : 01/02/2021 10:42 pm
(@darren-curtis)
Active Member

@softraid-support there is a list with about 20 snapshots but they are all listed as 11.2 and no 11.1 were available. Is that normal that a previous OS is not listed? Thank you.

ReplyQuote
Posted : 01/02/2021 10:52 pm
(@softraid-support)
Member Admin

No, but it is what I saw also. I do not understand. Especially as Apple removed 11.1 from the downloads today.

More research required on my end....

ReplyQuote
Posted : 01/02/2021 11:06 pm
(@hwgcom)
New Member

My M1mini auto upgraded as well, now will not mount Thunderbaymini Raid4, as others with no obvious errors, soft raid thinks drives are mounted.

Are you saying there is no hope for 11.2?  The only option is to try to revert to 11.1 or wait for 11.3?

ReplyQuote
Posted : 02/02/2021 11:45 am
(@softraid-support)
Member Admin

At the moment, that is the only option. there should be a 11.3 beta very soon. The fix is already in that beta apparently.

ReplyQuote
Posted : 02/02/2021 11:59 am
Page 10 / 13
Share:
close
open