Running SoftRaid on...
 
Notifications
Clear all

Running SoftRaid on Apple Silicon (M1) Macs including 2020 Mac Mini with M1

Page 9 / 13
(@softraid-support)
Member Admin

@sunstarfire

 

I will try to set this up tonight.

ReplyQuote
Posted : 05/01/2021 3:32 pm
(@yangster888)
Active Member

@softraid-support kernel panic seems to be appearing under the following two scenarios: 1) if I put my photos files in 4m2 (RAID5 6TB), Mac mini crashes after start up opens up softraid.  After I remove the photo folder and put it in another external drive TB3 SSD.  The problem stops, and 2) if I put the FCP library in 4m2 RAID5, Mac mini goes into kernel panic from time to time.  My current workaround is to use 4m2 as depository of fcpx library and video files.  move the fcpx library I'm currently working on to tb3 ssd.  I set up raid as hfs+, selected Digital video option (instead of default workstation).  also using caldigit tb3 as my main hub (to which tb3ssd is attached).  attaching the tech report.  Pls let me know if I'm doing something wrong.  ideally I would like to put all my video and photo files in 4m2 raid 5 without having to use tb3 ssd.  thanks for your help and happy new year

edit: I removed the photos folder by attaching 4m2 to my intel mbp (also running b48).  photos folder contains about 85G of raw, jpeg, and png files.  each of my fcpx library typically range from 50-200GB.

This post was modified 1 year ago by yangster888
ReplyQuote
Posted : 05/01/2021 6:45 pm
(@softraid-support)
Member Admin

@yangster888

 

I cannot test your FCP scenario, but photos, do you just mean your Photos library? That would be an easy test.

The external TB3 device, is it in SoftRAID format, or Apple format?

ReplyQuote
Posted : 05/01/2021 7:58 pm
(@effndc)
Active Member Customer

Repeated kernel panic and crashes today with B48, in fact I couldn't even boot the system with the external enclosure that SoftRAID manages connected as it was just in a kernel panic loop...as soon as SoftRAID started and mounted the volumes it would KP.  

Currently my DisplayPort monitor is downstream from my Thunderbay, which makes this a bit painful.  I had to remove the 4 SSDs from the Thunderbay in order to boot and login.  The path is an Apple TB3 to TB2 adapter, to Thunderbay, and then mini-DisplayPort to the monitor (sadly, you can't connect a miniDP monitor directly to the TB3-TB2 adapter).

ReplyQuote
Posted : 06/01/2021 4:31 pm
(@softraid-support)
Member Admin

@effndc

 

Did you get a panic log?

(more info, should bring up a box that you can copy all the text from, into text edit)

If you run this command in terminal, what is the output?

sudo kextstat -b com.softraid.driver.SoftRAID

ReplyQuote
Posted : 06/01/2021 5:23 pm
(@yangster888)
Active Member

@softraid-support not Photos (apple app) library, but folders containing raw/jpeg files (stored in tb3 device) for Lightroom (catalog & back up files stored in Mac mini).  tb3 device formatted in hfs+ journaled, not in softRAID format.

ReplyQuote
Posted : 06/01/2021 6:39 pm
(@nevermore)
New Member

I installed the SoftRAID 6.0.1 b48 Public Beta, and still can't get anything to work. I am on Big Sur 11.11, M1 Mac mini with 16 gigs. I reduced the security level as suggested. The Thunderbay 4 (set at Raid 5) will still not mount. Any suggestions? The Raid works on other computers, even without the SoftRaid installed. At this rate we will have to buy a new laptop just to get the work done, trying to avoid that so please reach out of you have suggestions.

This post was modified 1 year ago by Nevermore
ReplyQuote
Posted : 07/01/2021 2:45 am
(@softraid-support)
Member Admin

Did you "Allow" OWC as an identified developer?

Did that dialog box pop up when you installed the SoftRAID driver?

If you skipped that step, see if in System Preferences/Security, you can "Allow" OWC as an identified developer.

Otherwise, post a SoftRAID tech support file.

ReplyQuote
Posted : 07/01/2021 9:47 am
(@effndc)
Active Member Customer

@softraid-support I did not save the crash report from the dialog that popped up, just chose to submit it to Apple. I probably should have ran a `sysdiagnose` but didn't think of it at the time, as I was trying to get the system back to operational.  

238 0 0xfffffe0006ec0000 0x4000 0x4000 com.softraid.driver.SoftRAID (6.0.1b48) 52EDBB25-7BC4-3CC8-AF4B-C22CFC31895B <15 5 4 3>

I think I know what app's I/O activity triggered it last time and can attempt the same activity again to see if it reoccurs. 

ReplyQuote
Posted : 07/01/2021 6:03 pm
(@softraid-support)
Member Admin

@effndc

 

The problem with the M1 is there are no tools to debug a driver yet. I wanted to make sure the latest driver was loaded, it is.

 

If you can get precise steps, let me know. Especially if it does not require any apps I would not have, or could not imitate.

ReplyQuote
Posted : 07/01/2021 9:02 pm
Sunstarfire
(@sunstarfire)
Estimable Member

@nevermore Hey, just to remind you: Softraid 6 is in BETA, that is why it is called b48. If you go to an unsupported system with an unsupported driver, then it is definitely not Softraid's fault. So, complaining about the rate is not helping, Softraid's support and reaction times here are actually brilliant.

That said, did you create a support log? I have a Thunderbay on an M1 mini as a RAID4, and it works fine.

ReplyQuote
Posted : 09/01/2021 8:04 am
(@softraid-support)
Member Admin

@nevermore

The problem is most likely the driver is being blocked by macOS.

A) did you enable third party extension?

M1 Third party
https://support.apple.com/en-lk/guide/mac-help/mchl768f7291/mac
Select reduced security and enable this:
Select the “Allow user management of kernel extensions from identified developers” checkbox to allow installation of software that uses legacy kernel extensions.

B) did you Allow OWC as a identified developer in System Preferences/Security?

(and add the SoftRAID app to the privacy pane, Full Disk Access)

These must be done for all drivers in M1, or they cannot load. Confirm these are done. thanks!

ReplyQuote
Posted : 09/01/2021 9:11 am
(@softraid-support)
Member Admin

@sunstarfire

Yes, but everything should work. What is incomplete is the application. And we clearly need to add some kind of online assistance, as the rules in macOS changed over the past couple years. (and may keep changing)

ReplyQuote
Posted : 09/01/2021 9:12 am
(@pruthe)
Eminent Member

Hi @nevermore,

I also have a M1 Mac mini connected to a Thunderbay 4 running Raid5 and it does mount using b48. So as recommended, probably best to recheck install procedure and if still having problems, send support file.

Good Luck!

ReplyQuote
Posted : 09/01/2021 9:27 am
(@effndc)
Active Member Customer

@softraid-support It happened again.   I've tried to upload a TXT and a zip of the full crash problem report but your forum rejects the files, and your formatting tools are beyond bad 🤷‍♂️

I also have a 370MB sysdiagnose file I can share if you want it, please email me with a way to upload it privately or I can send Dropbox link as I don't want a sysdiagnose on the public Internet.

panic(cpu 0 caller 0xfffffe0018bd63a8): "complete() while dma active"
Debugger message: panic
Memory ID: 0xff
OS release type: User
OS version: 20C69

Kernel version: Darwin Kernel Version 20.2.0: Wed Dec  2 2021 PST 2020; root:xnu-7195.60.75~1/RELEASE_ARM64_T8101
Fileset Kernelcache UUID: 3E6AA74DF723BCB886499A5AAB34FA34
Kernel UUID: 48F71DB3-6C91-3E62-9576-3A1DCEF2B536
iBoot version: iBoot-6723.61.3
secure boot?: YES
Paniclog version: 13
KernelCache slide: 0x0000000010898000
KernelCache base:  0xfffffe001789c000
Kernel slide:      0x00000000113d8000
Kernel text base:  0xfffffe00183dc000
Kernel text exec base:  0xfffffe00184a4000
mach_absolute_time: 0x630832a0d0
Epoch Time:        sec       usec
  Boot    : 0x5ff92de0 0x00014810
  Sleep   : 0x00000000 0x00000000
  Wake    : 0x00000000 0x00000000
  Calendar: 0x5ff9730b 0x000b1971

CORE 0 recently retired instr at 0xfffffe001860d798
CORE 1 recently retired instr at 0xfffffe001860ec5c
CORE 2 recently retired instr at 0xfffffe001860ec5c
CORE 3 recently retired instr at 0xfffffe001860ec5c
CORE 4 recently retired instr at 0xfffffe001860ec60
CORE 5 recently retired instr at 0xfffffe001860ec60
CORE 6 recently retired instr at 0xfffffe001860ec60
CORE 7 recently retired instr at 0xfffffe001860ec60

Panicked task 0xfffffe166d1cdf18: 106357 pages, 537 threads: pid 0: kernel_task
Panicked thread: 0xfffffe167bfc1fb8, backtrace: 0xfffffe3fe4733700, tid: 7327
 lr: 0xfffffe00184f1f8c  fp: 0xfffffe3fe4733770
 lr: 0xfffffe00184f1d58  fp: 0xfffffe3fe47337e0
 lr: 0xfffffe0018613f5c  fp: 0xfffffe3fe4733800
 lr: 0xfffffe0018605914  fp: 0xfffffe3fe47338b0
 lr: 0xfffffe00184ab7e8  fp: 0xfffffe3fe47338c0
 lr: 0xfffffe00184f19e8  fp: 0xfffffe3fe4733c50
 lr: 0xfffffe00184f19e8  fp: 0xfffffe3fe4733cc0
 lr: 0xfffffe0018c8c3f8  fp: 0xfffffe3fe4733ce0
 lr: 0xfffffe0018bd63a8  fp: 0xfffffe3fe4733d40
 lr: 0xfffffe001a9e9050  fp: 0xfffffe3fe4733da0
 lr: 0xfffffe00177877e8  fp: 0xfffffe3fe4733e10
 lr: 0xfffffe00177852f8  fp: 0xfffffe3fe4733e30
 lr: 0xfffffe0018bbe26c  fp: 0xfffffe3fe4733e80
 lr: 0xfffffe0018bba2f4  fp: 0xfffffe3fe4733ec0
 lr: 0xfffffe0018bbb050  fp: 0xfffffe3fe4733f00
 lr: 0xfffffe00184b4c14  fp: 0x0000000000000000

      Kernel Extensions in backtrace:
         com.apple.iokit.IOStorageFamily(2.1)[970F9F25-186C-3C06-A313-4A484852E7D7]@0xfffffe001a9d0000->0xfffffe001a9effff
         com.softraid.driver.SoftRAID(6.0.1b48)[52EDBB25-7BC4-3CC8-AF4B-C22CFC31895B]@0xfffffe001775c000->0xfffffe0017797fff
            dependency: com.apple.iokit.IOStorageFamily(2.1)[970F9F25-186C-3C06-A313-4A484852E7D7]@0xfffffe001a9d0000->0xfffffe001a9effff
ReplyQuote
Posted : 09/01/2021 11:58 am
Page 9 / 13
Share:
close
open