Can't mount SoftRAI...
 
Notifications
Clear all

Can't mount SoftRAID RAID 5 volume when booted from external TB 3 drive

(@stevek)
Trusted Member Customer

TLDR: I installed Monterey on a TB 3 SSD connected directly to my M1 MacBook Air. My RAID 5 volume will not mount. When I try to mount it by right-clicking, it tries to mount but fails silently.

You mentioned a few days ago that there were issues running SoftRAID on an external drive, but that was in the Ventura dev beta forum. Does SoftRAID not work properly when booting from an external Thunderbolt 3 SSD running Monterey 12.5 beta 3?

After installing Monterey on that external I used Migration Assistant to bring over my internal setup with SotRAID. I rebooted into Recovery to change the Secutiry Optionss to "Allow user management of kernel extensions from identified developers: Allows installation of software that uses legacy kernel extensions." Restarted, Got multiple messages that disks were unrecognized with options to eject, ignore, etc. Looked for the Allow bit option in System Prefs > Security & Privacy but it wasn't there. Tried reinstalling drivers, restarted, Allow still isn't there. Still can't mount my RAID 5 volume.

I have an Apple RAID 0 set up in Disk Utility using two disks, one in a Thunderbay and the other in my TB 3 OWC Drive Dock and that works perfectly. Aren't SoftRAID and Apple RAID related?

Quote
Topic starter Posted : 19/06/2022 2:56 pm
(@softraid-support)
Member Admin

As of this time, your concern is correct, you cannot load the SoftRAID driver from an external drive. At some point, this should be fixed, but it may be a while. I will check with engineers to confirm that you cannot load the driver on Apple Silicon comptuers when booting from externals. this is a restriction specifically to ARM.

ReplyQuote
Posted : 20/06/2022 11:05 am
SteveK liked
(@stevek)
Trusted Member Customer

@softraid-support

What an absolute bummer.

I guess, for now, I can see if I can use symbolic links with iCloud Drive on the external M.2 that I wanted to boot from, while booting from my 256GB internal. 

ReplyQuote
Topic starter Posted : 20/06/2022 9:23 pm
(@pruthe)
Eminent Member

@softraid-support 

Same thing happens for me. I made a bootable backup of my M1 Mac mini (MacOS 12.4) using SuperDuper and when booting up on the external SSD, my external Softraid volumes (4 on single TB chain) will not mount. I can view the volumes on the Softraid app, but when requesting to mount using the app, they will not do so. FWIW, I have 2 Promise Pegasus R4 RAID 5 enclosures/volumes on same TB chain and they do not mount either. I do have a couple Apple formatted drives/volumes in my OWC enclosures and they do mount however.

Hope this gets fixed soon. :-)

ReplyQuote
Posted : 21/06/2022 10:29 am
(@softraid-support)
Member Admin

@pruthe 

This was a decision made, its not a bug.
I am hoping the release of new versions of driver kit helps.

Apple is locking down macOS like a henhouse with potential foxes outside.

With the inability to replace internal drives, we need to all buy systems with adequate internal storage, so alternate startup volumes can all be on the internal.

 

ReplyQuote
Posted : 21/06/2022 11:29 am
pruthe liked
Share:
close
open