Internal part of So...
 
Notifications
Clear all

Internal part of Softraid has stopped

Page 2 / 4
(@softraid-support)
Member Admin

We may have found a fix for this, which will be released in late October

ReplyQuote
Posted : 25/09/2019 3:47 pm
(@jouke)
New Member Customer

We may have found a fix for this, which will be released in late October

Hi, is there an update on this issue?
I just encountered the same bug when starting a verify action from the GUI
I'm on the latest version of SoftRAID (5.8.3) and macOS Mojave 10.14.6

Just wondering how far along a bugfix might be.

ReplyQuote
Posted : 29/04/2020 6:16 am
(@softraid-support)
Member Admin

We cannot find the exact trigger for this. We have reduced the frequency, but it still happens. Its annoying to engineering also!

ReplyQuote
Posted : 29/04/2020 1:39 pm
(@cheule)
Active Member Customer

I am running Mojave 10.14.6, and SoftRAID v5.8.3. If I leave the SoftRAID window open for a while (in excess of an hour) it will always "have an internal error." If you need me to gather any data for bug testing, let me know.

ReplyQuote
Posted : 28/05/2020 12:59 pm
(@softraid-support)
Member Admin

This is a very annoying SoftRAID bug. Here is one thing you can test for me.

Run the SoftRAID Pro 6 beta. Let me know if it also hangs.

https://softraid.com/srp_beta

We did not fix this bug yet, but I cannot get it to fail in my testing, so this is useful.

ReplyQuote
Posted : 28/05/2020 1:57 pm
(@rockdirector)
New Member

I have been unable to complete certification of ANY of the disk sets on two different Macs due to these errors.

This is happening continually and it is souring my confidence in (and willingness to purchase) Softraid.

ReplyQuote
Posted : 20/08/2020 8:01 am
(@softraid-support)
Member Admin

I am sorry about this, we have not been able to fix this. The SoftRAID Application is losing contact with the SoftRAID Monitor, which means the app must be restarted, but why is the question.

 

Since certify does not use the SoftRAID driver, the app must stay running to perform the certify.

If you start a new certify, it does pick up where it was if you do not make any setting changes.(not much consolation, I know)

 

I can also give you the command line to do a certify, the only problem is there is no feedback in terminal and it will need to start over. What you do is identify the BSD numbers for each disk, such as disk2 disk3 disk4 disk5 (use SoftRAID to identify the numbers, then you can quit the app)

If they are as above, then:

softraidtool disk disk2 disk3 disk4 disk5 certify 3

(3 is the number of passes)

 

There is no feedback until completion, however, when you get the command prompt back.

 

Its a very annoying issue. Surprised you are having this with two separate systems. Its not quite that common.

ReplyQuote
Posted : 20/08/2020 8:46 am
(@humanswin)
New Member

I just purchased SoftRAID and I was very disappointed to encounter this error multiple times on the first day, and in the days following.  I was even more disappointed to find this thread and to learn that there is no fix for it and that it's gone unsolved for so many months.  Had I known of this issue, I wouldn't have purchased the software.  I feel like I should get my money back.

ReplyQuote
Posted : 05/10/2020 11:36 am
(@softraid-support)
Member Admin

Remember first there is no need for the app to remain open, unless you are actively certifying.

 

This should be "rare", not multiple times a day. Are you really getting this every couple hours?

Assuming you are booted from Catalina, try a test with a clean install. (run Disk Utility, create a new volume (inside of your existing startup volume by clicking the + and create a volume not a partition.) Internet recovery boot and "reinstall MacOS" and select this volume. Run SoftRAID and let it sit for a evening. You are unlikley to get this app crash.

Let me know and quit SoftRAID when you are done with it. While this is getting less frequent with Catalina, we do not know what in the OS is triggering this. The app needing to quite is harmless as it does not affect the driver or Monitor, but the App loses contact with the Monitor, so needs to be relaunched.

 

Sometimes there is a memory usage increase when this happens, you can check when the app crashes to see if application memory is quickly increasing when you run the app.

 

ReplyQuote
Posted : 05/10/2020 12:25 pm
(@smayer97)
Eminent Member Customer

Same problem with Mojave 10.14.4 and SoftRAID 5.8.2. Is this strictly due to the version of macOS and updates or is there a version of SoftRAID that does NOT have this error?

ReplyQuote
Posted : 18/10/2020 6:22 am
(@softraid-support)
Member Admin

This is a MacOS "triggered" issue. I am not sure when this started, but I think High Sierra, when more security measures were implemented in macOS. We have made several attempts to fix this, nothing that worked 100%

ReplyQuote
Posted : 18/10/2020 3:40 pm
(@plgreco4u)
Active Member

I just started using SoftRAID on a MacBook Pro macOS 10.14.6 and came across this issue. I have two external 2TB Seagate Portable Drives and I converted drive A to non-RAID and I initialized drive B to mirror. I then attempted to convert drive A to mirror when this message came up and was unable to continue. After this every time I plug in drive B macOS panic crashes. It appears that something in drive B is triggering the crash but it might be the combination of the two drives. Any suggestions?

ReplyQuote
Posted : 19/11/2021 4:10 pm
(@softraid-support)
Member Admin

@plgreco4u

The partition map on B may be damaged, I am guessing.

If you connect only A, then it works?

What if you connect only B?

By itself can you initialize it?

if that works, then try using SoftRAID 6.0.5 to Convert. You do not need to install the driver (cancel when prompted), just run the app and now try to convert to Mirror.

Let me know.

https://softraid.com/updates/SoftRAID%206.0.5.dmg

ReplyQuote
Posted : 19/11/2021 6:45 pm
(@plgreco4u)
Active Member

Connecting only A works. Connecting only B also works. Connecting both crashes.

I was able to initialize B but when I tried to convert to mirror I got the error.

I am using SoftRAID 6.2 should I downgrade to 6.05?

 

ReplyQuote
Posted : 19/11/2021 7:05 pm
(@plgreco4u)
Active Member

@softraid-support

Connecting only A works. Connecting only B also works. Connecting both crashes.

I was able to initialize B but when I tried to convert to mirror I got the error.

I am using SoftRAID 6.2 should I downgrade to 6.05?

ReplyQuote
Posted : 19/11/2021 7:25 pm
Page 2 / 4
Share:
close
open