macOS 13 (Ventura) ...
 
Notifications
Clear all

[Sticky] macOS 13 (Ventura) public beta

Page 1 / 4
(@softraid-support)
Member Admin

Note: When SoftRAID 6.3 is released, we will release a 6.3.1 beta the same day.

It will be at the same link. the release of 6.3 will not work with Ventura.

macOS Ventura has significant user interface changes and while we encourage users to try it out and give us feedback on SoftRAID, keep in mind both Ventura and SoftRAID will be beta versions.

Here is a link to the current SoftRAID beta:

http://www.softraid.com/sr_beta

If you want to mention any issues, please attach a SoftRAID Technical Support file, which you can post to the forum. (Utilities menu)

We are aware that the driver says installation failed (SoftRAID B13), when it succeeded in fact, and there are some other driver installation issues. But overall, SoftRAID should work fine with Ventura.

This topic was modified 4 months ago by SoftRAID Support
This topic was modified 3 months ago by SoftRAID Support
Quote
Topic starter Posted : 09/06/2022 1:09 pm
Topic Tags
(@jollyjap)
Active Member

I am trying to set up a new Thunderblade 8TB  Using SoftRAID 6.2.1 did not work, it said only works on Mac OS12 and earlier. I downloaded the 6.3 Beta20 and the app loaded but had a SoftRAID Error 'An internal part of the SoftRAID Monitor has stopped functioning properly. Please quit SoftRAID and relaunch it. Relaunching is not making any difference. The app is not available to provide a support file due to the error

ReplyQuote
Posted : 10/07/2022 11:14 pm
(@softraid-support)
Member Admin

@jollyjap 

The beta should launch. There is a problem with Ventura beta 3 I have noticed. The computer can get stuck in a loop where the Monitor cannot launch. We reported this to Apple.

You can try this in the terminal:

sudo softraidtool unintall

to remove all components and give another shot at this.

(do not multi-thread-post on the forum)

 

ReplyQuote
Topic starter Posted : 11/07/2022 10:50 am
(@jollyjap)
Active Member

Thanks (sorry about the multi-thread). Tried in the terminal (changed to sudo softraidtool uninstall). Got this outcome

paulbartlett@SilverWolf ~ % sudo softraidtool uninstall

Uninstalling all SoftRAID components...

Executing: /usr/bin/kmutil install --volume-root / --check-rebuild

Unknown option '--check-rebuild'

SoftRAIDTool error: unable to uninstall SoftRAID.

### Tool execution stopped. Error #: 1.

Type "help" to see the help text

 

ReplyQuote
Posted : 11/07/2022 4:12 pm
(@softraid-support)
Member Admin

@jollyjap 

If you paste this into terminal, what is the output?

sudo kmutil load -p /Library/Extensions/SoftRAID.kext

ReplyQuote
Topic starter Posted : 11/07/2022 10:29 pm
(@jollyjap)
Active Member

@softraid-support nothing, just goes back to prompt (I have in the meantime deleted the app from the 'Applications Folder'

ReplyQuote
Posted : 11/07/2022 10:33 pm
(@softraid-support)
Member Admin

@jollyjap 

The application installs the driver, it can not delete the driver by deleting the app.

 

How about this:

sudo kextstat -b com.softraid.driver.SoftRAID

ReplyQuote
Topic starter Posted : 12/07/2022 12:18 am
(@jollyjap)
Active Member

@softraid-support

paulbartlett@SilverWolf ~ % sudo kextstat -b com.softraid.driver.SoftRAID

Password:

Executing: /usr/bin/kmutil showloaded --bundle-identifier com.softraid.driver.SoftRAID

No variant specified, falling back to release

Index Refs Address            Size       Wired      Name (Version) UUID <Linked Against>

  243    0 0xfffffe0006e785b0 0x1b99     0x1b99     com.softraid.driver.SoftRAID (6.3b20) EB34163C-EBEA-30A3-956C-7E0E731B1DF5 <17 5 4 3>

ReplyQuote
Posted : 12/07/2022 12:58 am
(@softraid-support)
Member Admin

@jollyjap 

This is good, all is normal.

There is another option. Disconnect the drives before launching SoftRAID. This should work to launch SoftRAID. You can tell if you see the startup disk in the disks column.

then connect your drives.

ReplyQuote
Topic starter Posted : 12/07/2022 12:14 pm
(@pruthe)
Eminent Member

I have a Mac system volume I use for beta testing that I initially set up to be a clone (including apps+data) of my Main Monterey volume (12.4). I recently upgraded to the Ventura public beta 3. Before I did this, I installed the Softraid beta 6.3b20 and made sure set up and working OK on Monterey before upgrading to Ventura. So far, my Softraid volumes (4, including 1 Raid 5 volume) are working fine on the Ventura beta. The Softraid app is working fine too, although I haven't tried any formatting functions on it.

Will let people know here if any problems encountered with Softraid on the Ventura betas.

M1 Mac mini

ReplyQuote
Posted : 12/07/2022 6:59 pm
(@jollyjap)
Active Member

@softraid-support I disconnected the drive, re-started the computer, installed SoftRAID 6.3B20. On starting Softraid I had the same monitor error.

Thanks for your assistance, but we don't seem to be getting too far. Probably best to wait until another Ventura Beta then try again?

ReplyQuote
Posted : 12/07/2022 7:27 pm
(@softraid-support)
Member Admin

@jollyjap 

But if you disconnect the drives before launching SoftRAID, it should launch.

Yes, hopefully next beta this will be fixed.

ReplyQuote
Topic starter Posted : 12/07/2022 8:59 pm
(@softraid-support)
Member Admin

@pruthe 

If you run into the "Monitor failed" error, launch without your disks connected, which should get around it.

Please post any oddities.

ReplyQuote
Topic starter Posted : 12/07/2022 9:00 pm
(@jollyjap)
Active Member

@softraid-support as discussed above I have tried this several times the outcome is the same if the drive is connected or not. I have also tried with all my attached drives disconnected (physically) and get the same outcome

ReplyQuote
Posted : 13/07/2022 12:16 am
(@softraid-support)
Member Admin

@jollyjap 

Is the driver quarantined?

sudo xattr /Library/Extensions/SoftRAID.kext

ReplyQuote
Topic starter Posted : 13/07/2022 12:53 am
Page 1 / 4
Share:
close
open