Ventura Beta 4 brea...
 
Notifications
Clear all

Ventura Beta 4 breaks Softraid support

Sunstarfire
(@sunstarfire)
Estimable Member

Good morning (here in Europe).

 

Ventura Beta 4 breaks Softraid support, at least for me. Here is how it looks like:

  • variant a: Apple has added a read-only driver for SoftRaid volumes, that mounts the volume before Softraid's own driver an. The volume is unusable as an active drive.
  • variant b: Apple has changed the order, in which drivers are run, and the read-only Softraid driver is loaded before Softraid's own
  • variant c: Apple just did something that keeps Softraid's own driver from running.

Whichever variant it is, the volume is mounted readonly and cannot be used for work. All the data is there, but that's it. I have not found a way to disable Ventura's own driver, and even with the latest Softraid beta (6.3.1b4), I cannot get Softraid to run. So for now my advice is:

Do not install the latest Ventura Beta 4 on a system that is running Softraid.

Hope there will be a solution soon. For now, I will downgrade to Monterey.

Take care you all.

 

S.

This topic was modified 2 weeks ago by Sunstarfire
Quote
Topic starter Posted : 28/07/2022 10:14 pm
Topic Tags
Sunstarfire
(@sunstarfire)
Estimable Member

Well, it seems like I was not totally right, I downgraded to Monterey, now I keep getting the error I had before. Funny enough, if I force kextload the driver, this is the error message I get:

 

(see below)

Kinda weird. Any explanations? It is a Mac Studio.... But it ran fine before. Dunno where this suddenly comes from.

 

Thanks,

S.

admin@AdminisacStudio ~ % sudo kmutil load -p /Library/Extensions/SoftRAID.kext

Password:

Error Domain=KMErrorDomain Code=71 "Incompatible architecture: Binary is for x86_64, but needed arch arm64e

Incompatible architecture: Binary is for x86_64, but needed arch arm64e

Incompatible architecture: Binary is for x86_64, but needed arch arm64e" UserInfo={NSLocalizedDescription=Incompatible architecture: Binary is for x86_64, but needed arch arm64e

Incompatible architecture: Binary is for x86_64, but needed arch arm64e

Incompatible architecture: Binary is for x86_64, but needed arch arm64e}

admin@AdminisacStudio ~ % 
ReplyQuote
Topic starter Posted : 28/07/2022 11:35 pm
(@softraid-support)
Member Admin

@sunstarfire 

THe "read only" problem is the volume directory is damaged, macOS attempted to repair, failed and mounted it read only.

There are no repair tools in M1, so backup restore is the only solution. (If you have an older intel system on Big Sur or older, Disk Warrior can repair the volume directory)

ReplyQuote
Posted : 29/07/2022 2:38 am
Share:
close
open